dev-python/pydns: Bump to 3.2.1
authorMichał Górny <mgorny@gentoo.org>
Sat, 25 Apr 2020 12:50:56 +0000 (14:50 +0200)
committerMichał Górny <mgorny@gentoo.org>
Sat, 25 Apr 2020 12:51:50 +0000 (14:51 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/pydns/Manifest
dev-python/pydns/pydns-3.2.1.ebuild [new file with mode: 0644]

index ea046dacf140531c47bfd36662b6ba893eeb3dc6..7d6690ee421375aa205687f4b7a2ed05868bc348 100644 (file)
@@ -1,2 +1,3 @@
 DIST py3dns-3.1.1.tar.gz 29981 BLAKE2B b8f1aaeb95764f4d332ec05a367557a24fdd9171e98349668995687052cbd392169a76aaf24e3d29c94ca1c232f04842b84a2320eab5e553de12c278af23975c SHA512 5f22ba12db502f997be4c2479697cc21fe15aac218da1d347bd400a3ab73d86ad32b57740292a10eacb73e07eba977f67b881e59be16f902afab47053efd6c6e
+DIST py3dns-3.2.1.tar.gz 30691 BLAKE2B 336ed91a3bf8b33db258667ac96eba6df361bb2a8f24c433dbc6754ea32a7284ce0463c392c1392538eed9d8bf9ea3f09400bc08f1970a7c96c52bf072606718 SHA512 22f16c571f9fad02a70a8e0bbbfd802f4f9af23946edb78e15f69f23e57411369274945a1dea5603acae1fc1eb404e5445207c541afb7864a60b92dc4d5477b3
 DIST pydns-2.3.6.tar.gz 28220 BLAKE2B 81d48c57bc90641c2e1667a951e3af3dc75dc1055e6f3f7b45e57d66bb1d391fc55ef0fa9fd261821de22c9119564cfc2b5a18f7a9780fe708b676c427824261 SHA512 261598c085c7d9f7adf5ce881814e444cdcf48a946dc17db467268ab6164f6045c204507cc58eff8e6f826b9786715ad2a9e766a72193ac8666969913180954b
diff --git a/dev-python/pydns/pydns-3.2.1.ebuild b/dev-python/pydns/pydns-3.2.1.ebuild
new file mode 100644 (file)
index 0000000..2e106c7
--- /dev/null
@@ -0,0 +1,33 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} pypy3 )
+
+inherit distutils-r1
+
+MY_PN="${PN/py/py3}"
+MY_P="${MY_PN}-${PV}"
+DESCRIPTION="Python DNS (Domain Name System) library"
+HOMEPAGE="https://launchpad.net/py3dns"
+SRC_URI="https://launchpad.net/${MY_PN}/trunk/${PV}/+download/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="CNRI"
+SLOT="3"
+KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~sparc ~x86"
+IUSE="examples"
+
+# Tests require network access
+RESTRICT="test"
+
+distutils_enable_tests unittest
+
+python_install_all() {
+       if use examples; then
+               docinto examples
+               dodoc -r tests/. tools/.
+               docompress -x /usr/share/doc/${PF}/examples
+       fi
+       distutils-r1_python_install_all
+}