dev-python/rfc3986: Modernize, py3.8
authorMichał Górny <mgorny@gentoo.org>
Tue, 28 Apr 2020 06:49:55 +0000 (08:49 +0200)
committerMichał Górny <mgorny@gentoo.org>
Tue, 28 Apr 2020 07:00:07 +0000 (09:00 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/rfc3986/rfc3986-1.3.2.ebuild

index 5d5064b5811db4b95470f062e91db5ee2cbe0d34..d30c59714ba3ffb546d8128b6ed5a904ea407f47 100644 (file)
@@ -2,7 +2,7 @@
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
-PYTHON_COMPAT=( python2_7 python3_{6,7} pypy3)
+PYTHON_COMPAT=( python2_7 python3_{6,7,8} pypy3)
 
 inherit distutils-r1
 
@@ -15,16 +15,13 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
 LICENSE="Apache-2.0"
 SLOT="0"
 KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
-IUSE="idna test"
-RESTRICT="!test? ( test )"
+IUSE="idna"
 
-DEPEND="
-       dev-python/setuptools[${PYTHON_USEDEP}]
+RDEPEND="
        idna? ( dev-python/idna[${PYTHON_USEDEP}] )
-       test? ( dev-python/pytest[${PYTHON_USEDEP}] )
 "
-RDEPEND=""
+BDEPEND="
+       test? ( dev-python/idna[${PYTHON_USEDEP}] )
+"
 
-python_test() {
-       py.test -vv || die
-}
+distutils_enable_tests pytest