dev-perl/frontier-rpc: EAPI6 + Tests
authorKent Fredric <kentnl@gentoo.org>
Sun, 22 Oct 2017 01:11:43 +0000 (14:11 +1300)
committerKent Fredric <kentnl@gentoo.org>
Sun, 22 Oct 2017 01:12:09 +0000 (14:12 +1300)
- EAPI6ify
- Enable tests

Package-Manager: Portage-2.3.8, Repoman-2.3.3

dev-perl/frontier-rpc/frontier-rpc-0.07_beta4-r2.ebuild [new file with mode: 0644]

diff --git a/dev-perl/frontier-rpc/frontier-rpc-0.07_beta4-r2.ebuild b/dev-perl/frontier-rpc/frontier-rpc-0.07_beta4-r2.ebuild
new file mode 100644 (file)
index 0000000..f34439c
--- /dev/null
@@ -0,0 +1,23 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_NAME=Frontier-RPC
+DIST_VERSION=0.07b4
+DIST_AUTHOR=KMACLEOD
+inherit perl-module
+
+DESCRIPTION="Perform remote procedure calls using extensible markup language"
+SRC_URI+=" http://perl-xml.sourceforge.net/xml-rpc/${DIST_NAME}-${DIST_VERSION}.tar.gz"
+HOMEPAGE+=" http://perl-xml.sourceforge.net/xml-rpc/"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND="
+       dev-perl/XML-Parser
+       dev-perl/libwww-perl
+"
+DEPEND="${RDEPEND}"