net-misc/ncman: EAPI=7 & multiple fixes in 9999
authorBen Kohler <bkohler@gentoo.org>
Fri, 20 Mar 2020 12:45:06 +0000 (07:45 -0500)
committerBen Kohler <bkohler@gentoo.org>
Fri, 20 Mar 2020 12:52:42 +0000 (07:52 -0500)
1) bump EAPI to 7
2) add musl build workaround
3) rework ebuild to unify with versioned snapshot ebuild

Package-Manager: Portage-2.3.94, Repoman-2.3.21
Signed-off-by: Ben Kohler <bkohler@gentoo.org>
net-misc/ncman/ncman-9999.ebuild

index 54dde8ba11c32a87cae9abc1f12478a1ea9d08bf..e5f04eaaaea0c612ef3c6d36d51ec67c61204a84 100644 (file)
@@ -1,21 +1,32 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=6
+EAPI=7
 
-inherit meson git-r3
-COMMIT="bca0dc0a835f8a267be28d32b49775a50543d081"
+inherit flag-o-matic meson
+COMMIT=""
+
+if [[ ${PV} == *9999* ]]; then
+       inherit git-r3
+       EGIT_REPO_URI=https://github.com/l4rzy/ncman.git
+else
+       SRC_URI="https://github.com/l4rzy/ncman/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+       KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+fi
 
 DESCRIPTION="An ncurses UI for connman, forked from connman-json-client"
 HOMEPAGE="https://github.com/l4rzy/ncman"
-EGIT_REPO_URI=https://github.com/l4rzy/ncman.git
 
 LICENSE="GPL-2"
 SLOT="0"
-KEYWORDS=""
 IUSE=""
 
 RDEPEND="dev-libs/json-c:0=
        >=sys-apps/dbus-1.4
        sys-libs/ncurses:0="
 DEPEND="${RDEPEND}"
+
+src_prepare() {
+       default
+       append-cflags "-D_POSIX_C_SOURCE=200809L"
+}