dev-libs/hyperscan: bump to 4.4.1-r1, fix 616626
authorChristian Roessner <c@roessner-network-solutions.com>
Wed, 26 Apr 2017 09:26:20 +0000 (11:26 +0200)
committerDirkjan Ochtman <djc@gentoo.org>
Wed, 26 Apr 2017 18:43:20 +0000 (20:43 +0200)
Gentoo-Bug: 616626

dev-libs/hyperscan/hyperscan-4.4.1-r1.ebuild [new file with mode: 0644]

diff --git a/dev-libs/hyperscan/hyperscan-4.4.1-r1.ebuild b/dev-libs/hyperscan/hyperscan-4.4.1-r1.ebuild
new file mode 100644 (file)
index 0000000..9bc34a0
--- /dev/null
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit cmake-utils
+
+DESCRIPTION="High-performance regular expression matching library"
+SRC_URI="https://github.com/01org/hyperscan/archive/v${PV}.tar.gz"
+HOMEPAGE="https://01.org/hyperscan"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="cpu_flags_x86_ssse3 static-libs"
+
+DEPEND="dev-util/ragel
+       =dev-lang/python-2*
+       dev-libs/boost
+       net-libs/libpcap"
+
+REQUIRED_USE="cpu_flags_x86_ssse3"
+
+src_configure() {
+       local mycmakeargs=(
+               -DBUILD_SHARED_LIBS=$(usex static-libs OFF ON)
+               -DBUILD_STATIC_AND_SHARED=$(usex static-libs ON OFF)
+       )
+       cmake-utils_src_configure
+}