dev-tcltk/scwoop: EAPI 7
authorTupone Alfredo <tupone@gentoo.org>
Sat, 12 Oct 2019 13:15:05 +0000 (15:15 +0200)
committerTupone Alfredo <tupone@gentoo.org>
Sat, 12 Oct 2019 13:15:05 +0000 (15:15 +0200)
Bug: https://bugs.gentoo.org/697338
Package-Manager: Portage-2.3.69, Repoman-2.3.16
Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
dev-tcltk/scwoop/scwoop-4.1-r1.ebuild [new file with mode: 0644]
dev-tcltk/scwoop/scwoop-4.1.ebuild

diff --git a/dev-tcltk/scwoop/scwoop-4.1-r1.ebuild b/dev-tcltk/scwoop/scwoop-4.1-r1.ebuild
new file mode 100644 (file)
index 0000000..16a2cf4
--- /dev/null
@@ -0,0 +1,28 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Simple Composite Widget Object Oriented Package"
+HOMEPAGE="http://jfontain.free.fr/scwoop41.htm"
+SRC_URI="http://jfontain.free.fr/${P}.tar.gz"
+
+LICENSE="jfontain"
+KEYWORDS="~amd64 ~ppc ~x86"
+SLOT="0"
+IUSE=""
+
+DEPEND="dev-tcltk/tcllib"
+RDEPEND="${DEPEND}"
+
+HTML_DOCS=( scwoop.htm )
+
+src_install() {
+       dodir /usr/lib/scwoop
+       ./instapkg.tcl "${D}"/usr/lib/scwoop || die
+
+       einstalldocs
+       docompress -x /usr/share/doc/${PF}/demo
+       docinto demo
+       dodoc demo*
+}
index 6a61670703e90d5101010801b64fb657a850c8c6..13f55586d5e33a9fe872df3fb19b6c104f6e3582 100644 (file)
@@ -13,6 +13,7 @@ SLOT="0"
 IUSE=""
 
 DEPEND="dev-tcltk/tcllib"
+RDEPEND="${DEPEND}"
 
 src_install() {
        dodir /usr/lib/scwoop