net-misc/icecast: shorten description for repoman, add libressl support
authorAnthony G. Basile <blueness@gentoo.org>
Tue, 23 Aug 2016 15:47:04 +0000 (11:47 -0400)
committerAnthony G. Basile <blueness@gentoo.org>
Tue, 23 Aug 2016 15:47:04 +0000 (11:47 -0400)
Package-Manager: portage-2.2.28

net-misc/icecast/icecast-2.4.3.ebuild

index e14dda3eb908c98cc7dadafc36529532083bfaa9..c06dccf0911bd640329bee8f6980b8ce52d28517 100644 (file)
@@ -5,14 +5,14 @@
 EAPI=6
 inherit autotools systemd user
 
-DESCRIPTION="An opensource alternative to shoutcast that supports mp3, ogg (vorbis/theora) and aac streaming"
+DESCRIPTION="Opensource alternative to shoutcast that supports mp3, ogg and aac streaming"
 HOMEPAGE="http://www.icecast.org/"
 SRC_URI="http://downloads.xiph.org/releases/icecast/${P}.tar.gz"
 
 LICENSE="GPL-2"
 SLOT="0"
 KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-fbsd"
-IUSE="kate logrotate +speex +ssl +theora +yp"
+IUSE="kate libressl logrotate +speex +ssl +theora +yp"
 
 #Although there is a --with-ogg and --with-orbis configure option, they're
 #only useful for specifying paths, not for disabling.
@@ -25,7 +25,10 @@ DEPEND="dev-libs/libxslt
        speex? ( media-libs/speex )
        theora? ( media-libs/libtheora )
        yp? ( net-misc/curl )
-       ssl? ( dev-libs/openssl:0= )"
+       ssl? (
+               !libressl? ( dev-libs/openssl:0= )
+               libressl? ( dev-libs/libressl:0= )
+       )"
 RDEPEND="${DEPEND}"
 
 pkg_setup() {