net-firewall/xtables-addons: version bump to 2.8
authorAnthony G. Basile <blueness@gentoo.org>
Sat, 22 Aug 2015 00:26:37 +0000 (20:26 -0400)
committerAnthony G. Basile <blueness@gentoo.org>
Sat, 22 Aug 2015 00:27:39 +0000 (20:27 -0400)
Package-Manager: portage-2.2.20.1

net-firewall/xtables-addons/Manifest
net-firewall/xtables-addons/xtables-addons-2.8.ebuild [new file with mode: 0644]

index 6da97030af9ba86b7316837033e9ca66ead3f3f3..e0b6f9f2dd5bbf2f8fe90642332381d6323b9f58 100644 (file)
@@ -4,3 +4,4 @@ DIST xtables-addons-2.1.tar.xz 316412 SHA256 1d788bf647d96cfbcc2e61c3a32702cfdde
 DIST xtables-addons-2.3.tar.xz 316452 SHA256 7ab43981d594131ec8d72d4604c92c25dcf67dd4cae6aabb71113238a27cdff9 SHA512 08d529f0a2fa96ba715d2142934d6568a3c4f0ddb49f06c3c4d4ac200de0a4d2b59a4007302b557ca21014cbacda104e7781df0d5158e5313a673a928453abcc WHIRLPOOL d9929c3ede195ae87fd5b063814f2d27a0ccc772b8cc7eaee7c4d551af58e9f91e4fbbf420c058522563ea9f7ee082e280f124118bee4997763eb35738e3facc
 DIST xtables-addons-2.6.tar.xz 313824 SHA256 6f2347df8fdcedfe871fe989e62bb79a729d12b600c057454b21fda8fe9d525b SHA512 e493c7a6e6512f8240d211b4ba5bb9ed705fcef604dca4b2ade717dd45046464087250b4057d9b66c94de92e090c0269e47e2cf665362bfe620b3a942d83d10d WHIRLPOOL f9f06cb1c5c2ca6cdf673ce0c2fabb6c971c3184e4197caf66e983ec5447261f574b10953bce8383f4a24a021bf58d32932a66b55d2e98ada5a15e1b8d3a60a5
 DIST xtables-addons-2.7.tar.xz 320804 SHA256 ce64b607967e576ac4d1f4fd522d0c4d34feada9fd45a54113967a6a2b56a519 SHA512 69c371b8bb5e464a4514dd432027be88a0ad5ab343bbe8c1f3cc2150f86e5a811de7a5d8fee2688499e5e49ac1dc275520eeae9afeeb51ec1cfaacc57892954a WHIRLPOOL 24c441e72764062adea16a32c3b2e9255645d17a7cfeddd1c0839761f003b78abaad2b25de4c1efce8fc62354b5023b91f8468f06ccec6c816ef1b2b02492ffc
+DIST xtables-addons-2.8.tar.xz 320864 SHA256 08af8c85ff00ee76469741bb9eb97454903680213dc3e0602266bcbb08788490 SHA512 337a0f9f8e1236a14977b1f60f82e9f6ea4b3d1134fb4ff29cdb7edfca54501639760e8f855ac803e259660a9a5afd7366770543e2f077346cb5dda8ef80462e WHIRLPOOL b09d0d05143ce052372827487e85b7e4c9674809007624371edb4a28155e7e6b605fa2518ba494f1a11cc7e3419675a69cea966a5d79fcfeaf9e273996e059ed
diff --git a/net-firewall/xtables-addons/xtables-addons-2.8.ebuild b/net-firewall/xtables-addons/xtables-addons-2.8.ebuild
new file mode 100644 (file)
index 0000000..936d85a
--- /dev/null
@@ -0,0 +1,186 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit eutils linux-info linux-mod multilib
+
+DESCRIPTION="extensions not yet accepted in the main kernel/iptables (patch-o-matic(-ng) successor)"
+HOMEPAGE="http://xtables-addons.sourceforge.net/"
+SRC_URI="mirror://sourceforge/xtables-addons/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="modules"
+
+MODULES="quota2 psd pknock lscan length2 ipv4options ipp2p iface gradm geoip fuzzy condition tarpit sysrq logmark ipmark echo dnetmap dhcpmac delude chaos account"
+
+for mod in ${MODULES}; do
+       IUSE="${IUSE} xtables_addons_${mod}"
+done
+
+DEPEND=">=net-firewall/iptables-1.4.5"
+
+RDEPEND="${DEPEND}
+       xtables_addons_geoip? (
+               app-arch/unzip
+               dev-perl/Text-CSV_XS
+               virtual/perl-Getopt-Long
+       )
+"
+
+DEPEND="${DEPEND}
+       virtual/linux-sources"
+
+SKIP_MODULES=""
+
+# XA_kernel_check tee "2 6 32"
+XA_check4internal_module() {
+       local mod=${1}
+       local version=${2}
+       local kconfigname=${3}
+
+       if use xtables_addons_${mod} && kernel_is -gt ${version}; then
+               ewarn "${kconfigname} should be provided by the kernel. Skipping its build..."
+               if ! linux_chkconfig_present ${kconfigname}; then
+                       ewarn "Please enable ${kconfigname} target in your kernel
+                       configuration or disable checksum module in ${PN}."
+               fi
+               # SKIP_MODULES in case we need to disable building of everything
+               # like having this USE disabled
+               SKIP_MODULES+=" ${mod}"
+       fi
+}
+
+pkg_setup()    {
+       if use modules; then
+               get_version
+               check_modules_supported
+               CONFIG_CHECK="NF_CONNTRACK NF_CONNTRACK_MARK ~CONNECTOR"
+               ERROR_CONNECTOR="Please, enable CONFIG_CONNECTOR if you wish to receive userspace notifications from pknock through netlink/connector"
+               linux-mod_pkg_setup
+
+               if ! linux_chkconfig_present IPV6; then
+                       SKIP_IPV6_MODULES="ip6table_rawpost"
+                       ewarn "No IPV6 support in kernel. Disabling: ${SKIP_IPV6_MODULES}"
+               fi
+               kernel_is -lt 3 7 && die "${P} requires kernel version >= 3.7, if you have older kernel please use 1.x version instead"
+       fi
+}
+
+# Helper for maintainer: cheks if all possible MODULES are listed.
+XA_qa_check() {
+       local all_modules
+       all_modules=$(sed -n '/^build_/{s/build_\(.*\)=.*/\L\1/;G;s/\n/ /;s/ $//;h}; ${x;p}' "${S}/mconfig")
+       if [[ ${all_modules} != ${MODULES} ]]; then
+               ewarn "QA: Modules in mconfig differ from \$MODULES in ebuild."
+               ewarn "Please, update MODULES in ebuild."
+               ewarn "'${all_modules}'"
+       fi
+}
+
+# Is there any use flag set?
+XA_has_something_to_build() {
+       local mod
+       for mod in ${MODULES}; do
+               use xtables_addons_${mod} && return
+       done
+
+       eerror "All modules are disabled. What do you want me to build?"
+       eerror "Please, set XTABLES_ADDONS to any combination of"
+       eerror "${MODULES}"
+       die "All modules are disabled."
+}
+
+# Parse Kbuid files and generates list of sources
+XA_get_module_name() {
+       [[ $# != 1 ]] && die "XA_get_sources_for_mod: needs exactly one argument."
+       local mod objdir build_mod sources_list
+       mod=${1}
+       objdir=${S}/extensions
+       # Take modules name from mconfig
+       build_mod=$(sed -n "s/\(build_${mod}\)=.*/\1/Ip" "${S}/mconfig")
+       # strip .o, = and everything before = and print
+       sources_list=$(sed -n "/^obj-[$][{]${build_mod}[}]/\
+               {s:obj-[^+]\+ [+]=[[:space:]]*::;s:[.]o::g;p}" \
+                               "${objdir}/Kbuild")
+
+       if [[ -d ${S}/extensions/${sources_list} ]]; then
+               objdir=${S}/extensions/${sources_list}
+               sources_list=$(sed -n "/^obj-m/\
+                       {s:obj-[^+]\+ [+]=[[:space:]]*::;s:[.]o::g;p}" \
+                               "${objdir}/Kbuild")
+       fi
+       for mod_src in ${sources_list}; do
+               has ${mod_src} ${SKIP_IPV6_MODULES} || \
+                       echo " ${mod_src}(xtables_addons:${S}/extensions:${objdir})"
+       done
+}
+
+# Die on modules known to fail on certain kernel version.
+XA_known_failure() {
+       local module_name=$1
+       local KV_max=$2
+
+       if use xtables_addons_${module_name} && kernel_is ge ${KV_max//./ }; then
+               eerror
+               eerror "XTABLES_ADDONS=${module_name} fails to build on linux ${KV_max} or above."
+               eerror "Either remove XTABLES_ADDONS=${module_name} or use an earlier version of the kernel."
+               eerror
+               die
+       fi
+}
+
+src_prepare() {
+       XA_qa_check
+       XA_has_something_to_build
+
+       # Bug #553630#c2.  echo fails on linux-4 and above.
+       XA_known_failure "echo" 4
+
+       local mod module_name
+       if use modules; then
+               MODULE_NAMES="compat_xtables(xtables_addons:${S}/extensions:)"
+       fi
+       for mod in ${MODULES}; do
+               if ! has ${mod} ${SKIP_MODULES} && use xtables_addons_${mod}; then
+                       sed "s/\(build_${mod}=\).*/\1m/I" -i mconfig || die
+                       if use modules; then
+                               for module_name in $(XA_get_module_name ${mod}); do
+                                       MODULE_NAMES+=" ${module_name}"
+                               done
+                       fi
+               else
+                       sed "s/\(build_${mod}=\).*/\1n/I" -i mconfig || die
+               fi
+       done
+       einfo "${MODULE_NAMES}" # for debugging
+
+       sed -e 's/depmod -a/true/' -i Makefile.in || die
+       sed -e '/^all-local:/{s: modules::}' \
+               -e '/^install-exec-local:/{s: modules_install::}' \
+                       -i extensions/Makefile.in || die
+
+       use xtables_addons_geoip || sed  -e '/^SUBDIRS/{s/geoip//}' -i Makefile.in
+}
+
+src_configure() {
+       set_arch_to_kernel # .. or it'll look for /arch/amd64/Makefile
+       econf --prefix="${EPREFIX}/" \
+               --libexecdir="${EPREFIX}/$(get_libdir)/" \
+               --with-kbuild="${KV_DIR}"
+}
+
+src_compile() {
+       emake CFLAGS="${CFLAGS}" CC="$(tc-getCC)" V=1
+       use modules && BUILD_PARAMS="V=1" BUILD_TARGETS="modules" linux-mod_src_compile
+}
+
+src_install() {
+       emake DESTDIR="${D}" install
+       use modules && linux-mod_src_install
+       dodoc -r README doc/*
+       find "${ED}" -type f -name '*.la' -exec rm -rf '{}' '+'
+}