Nuke usage of outdated string module, reformat imports
authorantarus <antarus@gentoo.org>
Sun, 1 Apr 2007 04:15:46 +0000 (04:15 -0000)
committerantarus <antarus@gentoo.org>
Sun, 1 Apr 2007 04:15:46 +0000 (04:15 -0000)
svn path=/; revision=371

trunk/src/epkginfo/epkginfo

index 17e8cba33f9b272a9fc4d5ce23db4137b79c0501..7d4447f7ff99dd2ec3409319da42b3e2237575ad 100755 (executable)
@@ -9,8 +9,10 @@
 
 # Gentoo metadata xml and arch keyword checking tool.
 
-import os,sys,portage
-import string,re
+import os
+import sys
+import portage
+import re
 from stat import *
 from output import *
 from xml.sax import saxutils, make_parser, handler
@@ -23,7 +25,7 @@ version="0.4.1"
 def getvar(pkg, var):
        file = open(pkg + ".ebuild")
        for line in file.readlines():
-               line = string.rstrip(line)
+               line = line.rstrip()
                if re.match("^"+var+"=",line):
                        vars = re.split("\"",line)[1]
                        file.close