dev-perl/Data-Random: Fix for '.' in @INC re bug #615588
authorKent Fredric <kentnl@gentoo.org>
Sun, 25 Jun 2017 08:02:52 +0000 (20:02 +1200)
committerKent Fredric <kentnl@gentoo.org>
Sun, 25 Jun 2017 08:03:23 +0000 (20:03 +1200)
Generic Module::Install fix

Bug: https://bugs.gentoo.org/615588
Package-Manager: Portage-2.3.6, Repoman-2.3.2

dev-perl/Data-Random/Data-Random-0.120.0.ebuild
dev-perl/Data-Random/Data-Random-0.80.0.ebuild

index 564f615c2dca046b4c578c68da64970881c51472..8c782a1033b7436e54bfe2741c2373a8be88a65f 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
@@ -29,6 +29,10 @@ src_prepare() {
        sed -i -e '/jsonmeta;/d'        \
                 -e '/githubmeta;/d'     \
                 Makefile.PL || die
+
+       sed -i -e 's/use inc::Module::Install;/use lib q[.];\nuse inc::Module::Install;/' Makefile.PL ||
+               die "Can't patch Makefile.PL for 5.26 dot-in-inc"
+
        perl-module_src_prepare
 }
 
index e0de76d3bdc0b0c97d175db42585e4ab5b2dfb0f..e66ad2c5b9082d9340fd9632131c95186b32b335 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=5
@@ -26,6 +26,9 @@ src_prepare() {
                -e '/^META.yml/d' \
                MANIFEST || die
 
+       sed -i -e 's/use inc::Module::Install;/use lib q[.];\nuse inc::Module::Install;/' Makefile.PL ||
+               die "Can't patch Makefile.PL for 5.26 dot-in-inc"
+
        perl-module_src_prepare
 }