virtual/x11; use flag cleanup; error check sed
authorMichael Sterrett <mr_bones_@gentoo.org>
Wed, 31 Mar 2004 05:20:53 +0000 (05:20 +0000)
committerMichael Sterrett <mr_bones_@gentoo.org>
Wed, 31 Mar 2004 05:20:53 +0000 (05:20 +0000)
games-roguelike/nethack/ChangeLog
games-roguelike/nethack/Manifest
games-roguelike/nethack/nethack-3.4.2.ebuild
games-roguelike/nethack/nethack-3.4.3.ebuild

index 5aa9b2847c586e680baadc349f9b8eeb1c43f07b..a54a8d31ee702dd2badf0feda034e0f011ec7dc8 100644 (file)
@@ -1,6 +1,10 @@
 # ChangeLog for games-roguelike/nethack
 # Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-roguelike/nethack/ChangeLog,v 1.6 2004/01/20 20:32:58 avenj Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-roguelike/nethack/ChangeLog,v 1.7 2004/03/31 05:20:53 mr_bones_ Exp $
+
+  30 Mar 2004; Michael Sterrett <mr_bones_@gentoo.org> nethack-3.4.2.ebuild,
+  nethack-3.4.3.ebuild:
+  virtual/x11; use flag cleanup; error check sed
 
   20 Jan 2004; Jon Portnoy <avenj@gentoo.org> :
   AMD64 keywords.
index bce0dbe09491be03906d77c5f761b69ee425814c..139df857222cc70ce7d6a096d47c33060206750b 100644 (file)
@@ -1,7 +1,7 @@
-MD5 08abf2f83e1578527c6af5d0a86464bc ChangeLog 3619
-MD5 2723553c895a7c8e1b986edf685e1875 nethack-3.4.2.ebuild 4295
-MD5 a30c9d4ce8f9629d6d7323eaab258343 metadata.xml 241
-MD5 3041c3accc85e0785ba33198ca16331a nethack-3.4.3.ebuild 4343
+MD5 1f83fff4faf7d282589b3ae8725b249d ChangeLog 3774
+MD5 f50dcf5575fa9e96bef828f97f3f6a41 nethack-3.4.2.ebuild 4250
+MD5 f17b9b8fa07a38914fe1c03268f51678 metadata.xml 158
+MD5 1cfdc905296d5c4b09e568b4fdbebd96 nethack-3.4.3.ebuild 4261
 MD5 7dfa79bba03a240cb7bba2e84d8178ef files/3.4.3-GNOME-support.patch 1316
 MD5 004669e4ce554b5f7f92daaea2e2cebb files/3.4.3-QT-GNOME-support.patch 1507
 MD5 d573c7b87f4add06cf21d3770b3c2f8f files/3.4.3-QT-support.patch 792
index 2735b80dfcc98a39b3c864567b6d9df558cd7de0..8af257b201a19dce0d35e905bb91c30e011abd31 100644 (file)
@@ -1,12 +1,10 @@
 # Copyright 1999-2004 Gentoo Technologies, Inc.
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-roguelike/nethack/nethack-3.4.2.ebuild,v 1.5 2004/02/20 06:55:42 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-roguelike/nethack/nethack-3.4.2.ebuild,v 1.6 2004/03/31 05:20:53 mr_bones_ Exp $
 
-inherit games eutils flag-o-matic gcc
-append-flags -I../include
+inherit eutils gcc flag-o-matic games
 
 MY_PV=${PV//.}
-
 DESCRIPTION="The ultimate old-school single player dungeon exploration game"
 HOMEPAGE="http://www.nethack.org/"
 SRC_URI="mirror://sourceforge/nethack/${PN}-${MY_PV}.tgz"
@@ -20,13 +18,14 @@ IUSE="X qt gnome"
 DEPEND="virtual/glibc
        dev-util/yacc
        >=sys-libs/ncurses-5.2-r5
-       X? ( x11-base/xfree )
+       X? ( virtual/x11 )
        qt? ( x11-libs/qt )
        gnome? ( >=gnome-base/gnome-libs-1.4.1.4-r2 )"
 
-HACKDIR=${GAMES_DATADIR}/${PN}
+HACKDIR="${GAMES_DATADIR}/${PN}"
 
 src_unpack() {
+       append-flags -I../include
        unpack ${A}
 
        # This copies the /sys/unix Makefile.*s to their correct places for 
@@ -39,15 +38,19 @@ src_unpack() {
        epatch ${FILESDIR}/${PV}-errno.patch
        epatch ${FILESDIR}/${PV}-default-options.patch
 
-       sed -i "s:GENTOO_STATEDIR:${GAMES_STATEDIR}/${PN}:" include/unixconf.h || die "setting statedir"
-       sed -i "s:GENTOO_HACKDIR:${HACKDIR}:" include/config.h || die "seting hackdir"
+       sed -i \
+               -e "s:GENTOO_STATEDIR:${GAMES_STATEDIR}/${PN}:" include/unixconf.h \
+                       || die "setting statedir"
+       sed -i \
+               -e "s:GENTOO_HACKDIR:${HACKDIR}:" include/config.h \
+                       || die "seting hackdir"
 
-       if [ `use X` ] ; then
+       if use X ; then
                epatch ${FILESDIR}/${PV}-X-support.patch
-               if [ `use qt` ] ; then
+               if use qt ; then
                        epatch ${FILESDIR}/${PV}-QT-support.patch
-                       [ `use gnome` ] && epatch ${FILESDIR}/${PV}-QT-GNOME-support.patch
-               elif [ `use gnome` ] ; then
+                       use gnome && epatch ${FILESDIR}/${PV}-QT-GNOME-support.patch
+               elif use gnome ; then
                        epatch ${FILESDIR}/${PV}-GNOME-support.patch
                fi
        fi
@@ -59,6 +62,7 @@ src_compile() {
                && qtver=3 \
                || qtver=2
        cd ${S}/src
+
        make \
                QTDIR=/usr/qt/${qtver} \
                CC="$(gcc-getCC)" \
@@ -79,7 +83,7 @@ src_install() {
                GAMEDIR=${D}${HACKDIR} \
                SHELLDIR=${D}/${GAMES_BINDIR} \
                install \
-               || die "make install failed"
+                       || die "make install failed"
        newgamesbin util/recover recover-nethack
 
        # The final nethack is a sh script.  This fixes the hard-coded
@@ -94,16 +98,16 @@ src_install() {
        insinto ${HACKDIR}
        doins ${FILESDIR}/dot.nethackrc
        local windowtypes="tty"
-       [ `use gnome` ] && windowtypes="${windowtypes} gnome"
-       [ `use qt` ] && windowtypes="${windowtypes} qt"
-       [ `use X` ] && windowtypes="${windowtypes} x11"
+       use gnome && windowtypes="${windowtypes} gnome"
+       use qt && windowtypes="${windowtypes} qt"
+       use X && windowtypes="${windowtypes} x11"
        set -- ${windowtypes}
        dosed "s:GENTOO_WINDOWTYPES:${windowtypes}:" ${HACKDIR}/dot.nethackrc
        dosed "s:GENTOO_DEFWINDOWTYPE:$1:" ${HACKDIR}/dot.nethackrc
        insinto /etc/skel
        newins ${D}/${HACKDIR}/dot.nethackrc .nethackrc
 
-       if [ `use X` ] ; then
+       if use X ; then
                # install nethack fonts
                cd ${S}/win/X11
                bdftopcf -o nh10.pcf nh10.bdf || die "Converting fonts failed"
@@ -137,11 +141,9 @@ src_install() {
 
 pkg_postinst() {
        games_pkg_postinst
-       if [ `use qt` ] ; then
-               if has_version '=x11-libs/qt-3.1*' ; then
-                       ewarn "the qt frontend may be a little unstable with this version of qt"
-                       ewarn "please see Bug 32629 for more information"
-               fi
+       if use qt && has_version '=x11-libs/qt-3.1*' ; then
+               ewarn "the qt frontend may be a little unstable with this version of qt"
+               ewarn "please see Bug 32629 for more information"
        fi
        einfo "you may want to look at /etc/skel/.nethackrc for interesting options"
 }
index a94fe682e6b4e3da9ec32c8f9677e668e3f05f25..f74cb4c09f4d121dc264e1e7441ede52b1eb05ff 100644 (file)
@@ -1,8 +1,8 @@
 # Copyright 1999-2004 Gentoo Technologies, Inc.
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-roguelike/nethack/nethack-3.4.3.ebuild,v 1.3 2004/02/29 21:04:19 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-roguelike/nethack/nethack-3.4.3.ebuild,v 1.4 2004/03/31 05:20:53 mr_bones_ Exp $
 
-inherit games eutils gcc flag-o-matic
+inherit eutils gcc flag-o-matic games
 
 MY_PV=${PV//.}
 DESCRIPTION="The ultimate old-school single player dungeon exploration game"
@@ -18,11 +18,11 @@ IUSE="X qt gnome"
 DEPEND="virtual/glibc
        dev-util/yacc
        >=sys-libs/ncurses-5.2-r5
-       X? ( x11-base/xfree )
+       X? ( virtual/x11 )
        qt? ( x11-libs/qt )
        gnome? ( >=gnome-base/gnome-libs-1.4.1.4-r2 )"
 
-HACKDIR=${GAMES_DATADIR}/${PN}
+HACKDIR="${GAMES_DATADIR}/${PN}"
 
 src_unpack() {
        unpack ${A}
@@ -36,15 +36,19 @@ src_unpack() {
        epatch ${FILESDIR}/${PV}-gentoo-paths.patch
        epatch ${FILESDIR}/${PV}-default-options.patch
 
-       sed -i "s:GENTOO_STATEDIR:${GAMES_STATEDIR}/${PN}:" include/unixconf.h || die "setting statedir"
-       sed -i "s:GENTOO_HACKDIR:${HACKDIR}:" include/config.h || die "seting hackdir"
+       sed -i \
+               -e "s:GENTOO_STATEDIR:${GAMES_STATEDIR}/${PN}:" include/unixconf.h \
+                       || die "setting statedir"
+       sed -i \
+               -e "s:GENTOO_HACKDIR:${HACKDIR}:" include/config.h \
+                       || die "seting hackdir"
 
-       if [ `use X` ] ; then
+       if use X ; then
                epatch ${FILESDIR}/${PV}-X-support.patch
-               if [ `use qt` ] ; then
+               if use qt ; then
                        epatch ${FILESDIR}/${PV}-QT-support.patch
-                       [ `use gnome` ] && epatch ${FILESDIR}/${PV}-QT-GNOME-support.patch
-               elif [ `use gnome` ] ; then
+                       use gnome && epatch ${FILESDIR}/${PV}-QT-GNOME-support.patch
+               elif use gnome ; then
                        epatch ${FILESDIR}/${PV}-GNOME-support.patch
                fi
        fi
@@ -77,7 +81,7 @@ src_install() {
                GAMEDIR=${D}${HACKDIR} \
                SHELLDIR=${D}/${GAMES_BINDIR} \
                install \
-               || die "make install failed"
+                       || die "make install failed"
        newgamesbin util/recover recover-nethack
 
        # The final nethack is a sh script.  This fixes the hard-coded
@@ -92,16 +96,16 @@ src_install() {
        insinto ${HACKDIR}
        doins ${FILESDIR}/dot.nethackrc
        local windowtypes="tty"
-       [ `use gnome` ] && windowtypes="${windowtypes} gnome"
-       [ `use qt` ] && windowtypes="${windowtypes} qt"
-       [ `use X` ] && windowtypes="${windowtypes} x11"
+       use gnome && windowtypes="${windowtypes} gnome"
+       use qt && windowtypes="${windowtypes} qt"
+       use X && windowtypes="${windowtypes} x11"
        set -- ${windowtypes}
        dosed "s:GENTOO_WINDOWTYPES:${windowtypes}:" ${HACKDIR}/dot.nethackrc
        dosed "s:GENTOO_DEFWINDOWTYPE:$1:" ${HACKDIR}/dot.nethackrc
        insinto /etc/skel
        newins ${D}/${HACKDIR}/dot.nethackrc .nethackrc
 
-       if [ `use X` ] ; then
+       if use X ; then
                # install nethack fonts
                cd ${S}/win/X11
                bdftopcf -o nh10.pcf nh10.bdf || die "Converting fonts failed"
@@ -135,11 +139,9 @@ src_install() {
 
 pkg_postinst() {
        games_pkg_postinst
-       if [ `use qt` ] ; then
-               if has_version '=x11-libs/qt-3.1*' ; then
-                       ewarn "the qt frontend may be a little unstable with this version of qt"
-                       ewarn "please see Bug 32629 for more information"
-               fi
+       if use qt && has_version '=x11-libs/qt-3.1*' ; then
+               ewarn "the qt frontend may be a little unstable with this version of qt"
+               ewarn "please see Bug 32629 for more information"
        fi
        einfo "you may want to look at /etc/skel/.nethackrc for interesting options"
 }