dev-ruby/mixlib-shellout: add 2.2.2
authorHans de Graaff <graaff@gentoo.org>
Tue, 20 Oct 2015 05:12:34 +0000 (07:12 +0200)
committerHans de Graaff <graaff@gentoo.org>
Tue, 20 Oct 2015 05:12:34 +0000 (07:12 +0200)
Package-Manager: portage-2.2.20.1

dev-ruby/mixlib-shellout/Manifest
dev-ruby/mixlib-shellout/mixlib-shellout-2.2.2.ebuild [new file with mode: 0644]

index a9cc5d30ec988d35f4b99346d95d149fb94ddb90..de560e396787924aa82261c42acad4a4c12c14d3 100644 (file)
@@ -1 +1,2 @@
 DIST mixlib-shellout-2.2.1.tar.gz 33307 SHA256 68e70a5ba15eca9ebf737f1ed21b3b90744b83f2856bf69e93f7b66348f67d03 SHA512 c9f9724b0929e07ba56a90508b167d6a6971aa7dabcecd320b8abd60a80dd0542e86b0570f3a9db5a76057ad8c4e1f9ec6ff38460a76ccd745a4996f1d69e297 WHIRLPOOL 29ad017b470312651e4c7c4a9f782184107c5e1527d8babf6de9c8a5040c094bb713dbd28bacdeeb5757ab37cb7a55025d137e022aeea9c8a81a9f4f28928b8b
+DIST mixlib-shellout-2.2.2.tar.gz 33495 SHA256 ecd1b4612465ab650b568c85af05c26cdea874d1bf00586b2c76830dd040bae6 SHA512 8ae64988347786c11c208f648a6b65d3e4b70822175ead4081e0073287baa1a61956193e82d48e7fe03f03c58c5b8678716579d70abb576f5531d32fba50e4c5 WHIRLPOOL f818fea924d616e2a64eb718dd3329e15bb304736985ce8eaa0a223c36db20a18a2e464dbe983292c6cebe1b3c4ddeb8683155c89d95985f79e91e645f4b8a60
diff --git a/dev-ruby/mixlib-shellout/mixlib-shellout-2.2.2.ebuild b/dev-ruby/mixlib-shellout/mixlib-shellout-2.2.2.ebuild
new file mode 100644 (file)
index 0000000..6d1fc6f
--- /dev/null
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_EXTRA_DOC="CHANGELOG.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Run external commands on Unix or Windows"
+HOMEPAGE="https://github.com/opscode/mixlib-shellout"
+SRC_URI="https://github.com/opscode/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+each_ruby_prepare() {
+       # Make sure we actually use the right interpreter for testing
+       sed -i -e "/ruby_eval/ s:ruby :${RUBY} :" spec/mixlib/shellout_spec.rb || die
+}