media-video/handbrake: Sync/Fix live ebuild
authorIan Whyman <thev00d00@gentoo.org>
Wed, 20 Nov 2019 18:33:04 +0000 (18:33 +0000)
committerIan Whyman <thev00d00@gentoo.org>
Wed, 20 Nov 2019 18:33:08 +0000 (18:33 +0000)
Package-Manager: Portage-2.3.79, Repoman-2.3.18
Signed-off-by: Ian Whyman <thev00d00@gentoo.org>
media-video/handbrake/files/handbrake-9999-libdl-link.patch [deleted file]
media-video/handbrake/handbrake-9999.ebuild

diff --git a/media-video/handbrake/files/handbrake-9999-libdl-link.patch b/media-video/handbrake/files/handbrake-9999-libdl-link.patch
deleted file mode 100644 (file)
index ace1528..0000000
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/gtk/configure.ac b/gtk/configure.ac
-index 92aabcbe8..1f4a1df95 100644
---- a/gtk/configure.ac
-+++ b/gtk/configure.ac
-@@ -199,7 +199,7 @@ PKG_CHECK_MODULES(GHB, [$GHB_PACKAGES])
- GHB_CFLAGS="$HBINC $GHB_CFLAGS"
--HB_LIBS="-lhandbrake -lavformat -lavfilter -lavcodec -lavutil -ldav1d -lswresample -lpostproc -ldvdnav -ldvdread -lmp3lame -lvorbis -lvorbisenc -logg -lx264 -lswscale -ltheoraenc -ltheoradec -lvpx -lz -lbz2 -lbluray -lass -lfontconfig -lfreetype -lxml2 -ljansson -lopus -lspeex -llzma"
-+HB_LIBS="-lhandbrake -lavformat -lavfilter -lavcodec -lavutil -ldav1d -lswresample -lpostproc -ldvdnav -ldvdread -lmp3lame -lvorbis -lvorbisenc -logg -lx264 -lswscale -ltheoraenc -ltheoradec -lvpx -lz -lbz2 -lbluray -lass -lfontconfig -lfreetype -lxml2 -ljansson -lopus -lspeex -llzma -ldl"
- if test "x$use_fdk_aac" = "xyes" ; then
-     HB_LIBS="$HB_LIBS -lfdk-aac"
index 13e3bf9a6ad8490dcc1422e7a64d5913421daa0e..cfc362cad18f52833cc88a79fb2ad27ace9f4489 100644 (file)
@@ -23,7 +23,7 @@ HOMEPAGE="http://handbrake.fr/"
 LICENSE="GPL-2"
 
 SLOT="0"
-IUSE="+fdk gstreamer gtk libav libav-aac nvenc x265"
+IUSE="+fdk gstreamer gtk libav libav-aac numa nvenc x265"
 
 REQUIRED_USE="^^ ( fdk libav-aac )"
 
@@ -71,7 +71,7 @@ RDEPEND="
                x11-libs/pango
        )
        fdk? ( media-libs/fdk-aac )
-       x265? ( >=media-libs/x265-2.9:0= )
+       x265? ( >=media-libs/x265-3.2:0=[10bit,12bit,numa?] )
        "
 
 DEPEND="${RDEPEND}
@@ -88,14 +88,10 @@ PATCHES=(
        # Remove faac dependency; TODO: figure out if we need to do this at all.
        "${FILESDIR}/${PN}-9999-remove-faac-dependency.patch"
 
-       # Fix missing -ldl
-       "${FILESDIR}/${PN}-9999-libdl-link.patch"
+       # Use whichever python is set by portage
+       "${FILESDIR}/${PN}-1.3.0-dont-search-for-python.patch"
 )
 
-pkg_setup() {
-       python-any-r1_pkg_setup
-}
-
 src_prepare() {
        # Get rid of leftover bundled library build definitions,
        sed -i 's:.*\(/contrib\|contrib/\).*::g' \
@@ -125,6 +121,7 @@ src_configure() {
                $(use_enable fdk fdk-aac) \
                $(usex !gtk --disable-gtk) \
                $(usex !gstreamer --disable-gst) \
+               $(use_enable numa) \
                $(use_enable nvenc) \
                $(use_enable x265) || die "Configure failed."
 }