sys-apps/flashrom: live ebuild: compile and install libflashrom
authorMarek Szuba <marecki@gentoo.org>
Mon, 30 Mar 2020 22:08:38 +0000 (23:08 +0100)
committerMarek Szuba <marecki@gentoo.org>
Mon, 30 Mar 2020 22:40:00 +0000 (23:40 +0100)
Signed-off-by: Marek Szuba <marecki@gentoo.org>
sys-apps/flashrom/flashrom-9999.ebuild

index 44446c7c4e171e37f5a3254cc7e1b48ead4d4155..465d5969df38c82eba22d73b1ea9b679573db19e 100644 (file)
@@ -138,7 +138,7 @@ src_compile() {
        fi
 
        tc-export AR CC PKG_CONFIG RANLIB
-       emake WARNERROR=no "${args[@]}"
+       emake WARNERROR=no "${args[@]}" all libflashrom.a
 }
 
 src_test() {
@@ -153,6 +153,8 @@ src_install() {
        dosbin flashrom
        doman flashrom.8
        dodoc README Documentation/*.txt
+       dolib.a libflashrom.a
+       doheader libflashrom.h
 
        if use tools ; then
                if use amd64 ; then