dev-perl/Text-Template: Bump to version 1.510.0
authorKent Fredric <kentnl@gentoo.org>
Tue, 13 Mar 2018 07:22:39 +0000 (20:22 +1300)
committerKent Fredric <kentnl@gentoo.org>
Tue, 13 Mar 2018 07:22:39 +0000 (20:22 +1300)
Upstream:
- Allow precompiled templates to work with preprocessing
- Add "strict" option to fill_in
- Fix templates with inline comments without newline after comment
- Fix BROKEN behaviour to return accumulated text so far
- Fix FILENAME parameter to fill_in

Package-Manager: Portage-2.3.24, Repoman-2.3.6

dev-perl/Text-Template/Manifest
dev-perl/Text-Template/Text-Template-1.510.0.ebuild [new file with mode: 0644]

index e60ae89d9f1ea3556996a52f6471d6aa9b45ecf1..73bd27df4f4cebd8c1e43a7216f49351288c1bb3 100644 (file)
@@ -1,2 +1,3 @@
 DIST Text-Template-1.46.tar.gz 43952 BLAKE2B 6dff627f7924e0a84528687245da5b69ecaba8dbe26fd932e09b4486cc74743ae98e6874a0062566ae2339f6f2f1d7364c7cae292111b1c815c52ceddec30338 SHA512 406c218d5d59dc74419749fb5151d011fb4d629e6de79378be1290db23a602a9f7897f04ac80080b8ec2661d997f9e05bed7861e480130750471166da0a94592
 DIST Text-Template-1.47.tar.gz 48988 BLAKE2B a34bc1b4dc7e29f5171d9aa5da21d9083763701ba19ff9f50ca488f8a3936181fc17f7d8e517743fc77ac7e8f688aea33a802c949edfff3c61b79b7f272ca489 SHA512 af5ad3fc8191d2dd8609735b6a7d6221e4f7ec668c6bc35650081fee248cdc9676984302d420ac227baf8d2de6f6eb023e01f54290b90508e294ba4309b0e68e
+DIST Text-Template-1.51.tar.gz 48054 BLAKE2B ca44e383799624949a5fa05de288a86351422cf7e4efcdb7f1a98b16216443aa3e269f7e69eb134458e889250133aa81dd15922b8a20ab4bf83b92fc16ac82ed SHA512 038a810746684b26cd6a763cfb8adff57a2ed8dc57e44b170b6ba6c8271d513289546294439cfe1c8b77f40153751596a023079ee79bfc6b59fa9393cfcc04f4
diff --git a/dev-perl/Text-Template/Text-Template-1.510.0.ebuild b/dev-perl/Text-Template/Text-Template-1.510.0.ebuild
new file mode 100644 (file)
index 0000000..c0addce
--- /dev/null
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=MSCHOUT
+DIST_VERSION=1.51
+inherit perl-module
+
+DESCRIPTION="Expand template text with embedded Perl"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~x86 ~ppc-macos"
+IUSE="test"
+
+RDEPEND="
+       virtual/perl-Carp
+       virtual/perl-Exporter
+"
+DEPEND="${RDEPEND}
+       virtual/perl-ExtUtils-MakeMaker
+       test? (
+               virtual/perl-File-Temp
+               virtual/perl-Safe
+               virtual/perl-Test-Simple
+               dev-perl/Test-Warnings
+       )
+"
+PERL_RM_FILES=( "t/author-pod-syntax.t" "t/author-signature.t" )