dev-python/asset: dev-python/asset: Version Bump
authorJustin Lecher <jlec@gentoo.org>
Tue, 18 Aug 2015 07:00:37 +0000 (09:00 +0200)
committerJustin Lecher <jlec@gentoo.org>
Tue, 18 Aug 2015 07:00:37 +0000 (09:00 +0200)
Package-Manager: portage-2.2.20.1
Signed-off-by: Justin Lecher <jlec@gentoo.org>
dev-python/asset/Manifest
dev-python/asset/asset-0.6.2.ebuild [new file with mode: 0644]

index 60a6ce5ec2a632630ba47883523b7ff2a85938e7..c9db91b826008104429ccdc7f48582e2d2ff84d4 100644 (file)
@@ -1 +1,2 @@
 DIST asset-0.6.1.tar.gz 20613 SHA256 071fcbf93b03d791b4e301c1459dc6bd1779407f9c0326fa136f03449c4bb4c4 SHA512 6fa20888220e83a0a122b8ab63e531551724c64476c3fce8f47f784731710fa3328fa4ac3855bde5fb4caed47274f0492e14df438cf7857c0e5437f33217b672 WHIRLPOOL ca266bb9969e7b4f1b8a7940928ac3dac169374b5c7e44af091f112dcee975ed8d699bcf864645c2122ca3b503e54357a25884d7d2f97c32ae6ad67d67354fc9
+DIST asset-0.6.2.tar.gz 20961 SHA256 5d4e5735a28408e84a61cbf22b41736fa2dfbe8807df2a4b50d2fa8ef3e0f0f9 SHA512 c1337b28cb55127e987003f2c4f14df6dd2b86252e8884a44e10f6aede2387ddeb007f8e0426417dc1ec1fa56c4d5d4491173bf451542caf9f6ac5c78b871f90 WHIRLPOOL b68c268ad8b446da1770105aec70e3e45969a4906c290831c22375c9a7c2788f7c64493ad6970e20b5521a2a6d016aef708098b2b03549703e059678ba51e89c
diff --git a/dev-python/asset/asset-0.6.2.ebuild b/dev-python/asset/asset-0.6.2.ebuild
new file mode 100644 (file)
index 0000000..4e48fbd
--- /dev/null
@@ -0,0 +1,34 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4} )
+
+inherit distutils-r1
+
+DESCRIPTION="A package resource and symbol loading helper library"
+HOMEPAGE="https://pypi.python.org/pypi/asset http://github.com/metagriffin/asset"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-3+"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+       >=dev-python/globre-0.0.5[${PYTHON_USEDEP}]
+       >=dev-python/six-1.4.1[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+       test? (
+               >=dev-python/nose-1.3.0[${PYTHON_USEDEP}]
+               >=dev-python/pxml-0.2.11[${PYTHON_USEDEP}]
+       )"
+
+PATCHES=( "${FILESDIR}"/${PN}-0.6.1-broken-test.patch )
+
+python_test() {
+       nosetests --verbose || die
+}