x11-themes/elementary-xfce-icon-theme: Bump to 0.15
authorMichał Górny <mgorny@gentoo.org>
Tue, 24 Mar 2020 07:25:32 +0000 (08:25 +0100)
committerMichał Górny <mgorny@gentoo.org>
Tue, 24 Mar 2020 07:55:28 +0000 (08:55 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
x11-themes/elementary-xfce-icon-theme/Manifest
x11-themes/elementary-xfce-icon-theme/elementary-xfce-icon-theme-0.15.ebuild [new file with mode: 0644]

index 51e1aa7905b1ff19a947be170b8ce45aa239fd44..323049b1e36b99697b95636505d9fcce09ab4e7c 100644 (file)
@@ -1 +1,2 @@
 DIST elementary-xfce-0.14.tar.gz 6265406 BLAKE2B 8f51e42224d4c458094855b1a807a726ec3f85ce3a9f0a676b8736d6c5d68141e137c4e7257e762dfd9d50260409c2da0cb954f23b96b4632ebeab818d050b73 SHA512 014d438699152585531942f1cff864f019c594b37de433831f3f941622b8cd5182e2537a114638d3af42f79409c0b0406bc0e71261688717e70a1914c9155756
+DIST elementary-xfce-0.15.tar.gz 6178898 BLAKE2B 9b15a850a91c6d2fc598efe463c66dfeaecd70c45131c387e303ad471076b26f95c151cc3534e34e3d00c05334cfb601a2683492bcde64d326b4a2efa94fde68 SHA512 35434671d81ef5ad61562360faa54752da7351c1d885efc5dd3dffd5af86bb3ba91aa9f20433e237ccd6eb9ffadf1342a7c77a4a83154c8655fd076eca9107b3
diff --git a/x11-themes/elementary-xfce-icon-theme/elementary-xfce-icon-theme-0.15.ebuild b/x11-themes/elementary-xfce-icon-theme/elementary-xfce-icon-theme-0.15.ebuild
new file mode 100644 (file)
index 0000000..9d36aba
--- /dev/null
@@ -0,0 +1,46 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit xdg-utils toolchain-funcs
+
+MY_P="${PN%-icon-theme}-${PV}"
+DESCRIPTION="Elementary icons forked from upstream, extended and maintained for Xfce"
+HOMEPAGE="https://github.com/shimmerproject/elementary-xfce"
+SRC_URI="https://github.com/shimmerproject/elementary-xfce/archive/v${PV}.tar.gz -> ${MY_P}.tar.gz"
+
+LICENSE="public-domain GPL-1 GPL-2 GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND="media-gfx/optipng
+       sys-apps/findutils
+       x11-libs/gdk-pixbuf:2
+       x11-libs/gtk+:3"
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+       # custom script
+       ./configure --prefix="${EPREFIX}/usr" || die
+}
+
+src_compile() {
+       emake CC="$(tc-getCC)"
+}
+
+src_install() {
+       default
+       # delete dangling doc links
+       find -L "${D}" -type l -delete || die
+}
+
+pkg_postinst() {
+       xdg_icon_cache_update
+}
+
+pkg_postrm() {
+       xdg_icon_cache_update
+}