sys-devel/llvm: Force x86 CHOST to i386-* for compiler-rt compat
authorMichał Górny <mgorny@gentoo.org>
Mon, 23 Jan 2017 19:33:00 +0000 (20:33 +0100)
committerMichał Górny <mgorny@gentoo.org>
Mon, 23 Jan 2017 21:36:07 +0000 (22:36 +0100)
Force x86 CHOST value to be i386-* since clang uses the exact arch value
to find compiler-rt libraries, and our compiler-rt libraries are named
'i386' unconditionally. It should still be able to find gcc install by
using alternate triple aliases.

sys-devel/llvm/llvm-4.0.0_rc1.ebuild
sys-devel/llvm/llvm-9999.ebuild

index bbd935aa11dd3f1ca3c02f846f0f47915bc4a0d4..ab685cbdf59160e605cf7e90510983dd3907ea47 100644 (file)
@@ -156,7 +156,10 @@ multilib_src_configure() {
 
                -DWITH_POLLY=OFF # TODO
 
-               -DLLVM_HOST_TRIPLE="${CHOST}"
+               # 'normalize' x86 triples to i386-* since this is the name used
+               # by compiler-rt libraries.
+               # remove this when https://reviews.llvm.org/D26796 is merged
+               -DLLVM_HOST_TRIPLE="${CHOST/#i[4-9]86-/i386-}"
 
                -DFFI_INCLUDE_DIR="${ffi_cflags#-I}"
                -DFFI_LIBRARY_DIR="${ffi_ldflags#-L}"
index a66f1e10dc84deb5001fb56b8b9734babfee8b3e..49c65e2b36d02cbd697c79697957cbb3a3f4962b 100644 (file)
@@ -154,7 +154,10 @@ multilib_src_configure() {
 
                -DWITH_POLLY=OFF # TODO
 
-               -DLLVM_HOST_TRIPLE="${CHOST}"
+               # 'normalize' x86 triples to i386-* since this is the name used
+               # by compiler-rt libraries.
+               # remove this when https://reviews.llvm.org/D26796 is merged
+               -DLLVM_HOST_TRIPLE="${CHOST/#i[4-9]86-/i386-}"
 
                -DFFI_INCLUDE_DIR="${ffi_cflags#-I}"
                -DFFI_LIBRARY_DIR="${ffi_ldflags#-L}"