www-client/firefox: don't enable XINPUT2 for KWin users
authorThomas Deutschmann <whissi@gentoo.org>
Thu, 2 Apr 2020 21:16:14 +0000 (23:16 +0200)
committerThomas Deutschmann <whissi@gentoo.org>
Thu, 2 Apr 2020 21:18:50 +0000 (23:18 +0200)
Closes: https://bugs.gentoo.org/715604
Package-Manager: Portage-2.3.96, Repoman-2.3.22
Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
www-client/firefox/files/firefox.sh
www-client/firefox/firefox-68.6.0-r4.ebuild [moved from www-client/firefox/firefox-68.6.0-r3.ebuild with 100% similarity]
www-client/firefox/firefox-74.0-r3.ebuild [moved from www-client/firefox/firefox-74.0-r2.ebuild with 100% similarity]

index f1fde8fdfce0655453d27c3fc62e0d05083fd8ae..c08d555196d6ce83edcfd2f76f81700b92b9de14 100644 (file)
@@ -93,7 +93,25 @@ fi
 ##
 ## Enable Xinput2 (#617344)
 ##
-export MOZ_USE_XINPUT2=1
+
+# respect user settings
+MOZ_USE_XINPUT2=${MOZ_USE_XINPUT2:-auto}
+
+if [[ ${MOZ_USE_XINPUT2} == auto && -n ${WAYLAND_DISPLAY} ]]; then
+       # enabling XINPUT2 should be safe for all wayland users
+       MOZ_USE_XINPUT2=1
+elif [[ ${MOZ_USE_XINPUT2} == auto && ${XDG_CURRENT_DESKTOP^^} == KDE ]]; then
+       # XINPUT2 is known to cause problems for KWin users
+       MOZ_USE_XINPUT2=0
+elif [[ ${MOZ_USE_XINPUT2} == auto && ${XDG_CURRENT_DESKTOP^^} == LXQT ]]; then
+       # LXQt uses KWin
+       MOZ_USE_XINPUT2=0
+elif [[ ${MOZ_USE_XINPUT2} == auto ]]; then
+       # should work on Mate, Xfce, FluxBox, OpenBox and all the others ...
+       MOZ_USE_XINPUT2=1
+fi
+
+[[ ${MOZ_USE_XINPUT2} != 0 ]] && export MOZ_USE_XINPUT2=${MOZ_USE_XINPUT2}
 
 # Don't throw "old profile" dialog box.
 export MOZ_ALLOW_DOWNGRADE=1