app-editors/vim: version bump to 8.1.0648
authorTim Harder <radhermit@gentoo.org>
Fri, 28 Dec 2018 09:00:59 +0000 (03:00 -0600)
committerTim Harder <radhermit@gentoo.org>
Fri, 28 Dec 2018 09:08:16 +0000 (03:08 -0600)
Closes: https://bugs.gentoo.org/666680

Signed-off-by: Tim Harder <radhermit@gentoo.org>
app-editors/vim/Manifest
app-editors/vim/vim-8.1.0648.ebuild [new file with mode: 0644]
app-editors/vim/vim-9999.ebuild

index 100f5698d8fcfbca2442efad8c19301e9d9b8a63..03ef5c341e286d71bb6ca7cf9aaf27a5812cc72c 100644 (file)
@@ -3,3 +3,4 @@ DIST vim-8.0.1298.tar.gz 13395459 BLAKE2B 4b6e3c4443cd675dc3727e8609b89c422f66c7
 DIST vim-8.0.1699.tar.gz 13546105 BLAKE2B cabf29d5a89c55e2fe3bc5e39eb499412f5907ddf856f8644b466f1e0fbffefff3cd801b6bc5e49e62ffdf8805b0556058b9a913015a9f9fbe1a4f580132fd49 SHA512 b0fe8e1dc05fdc3758896caf4746da40988ca7604d77dbe78c47525cbf8f0d7e6c05f690687268eda581009050d4e02e93fb4d30734cbbab4cfd6a8a1488c1e7
 DIST vim-8.1.0034.tar.gz 13652586 BLAKE2B 98dac6b37c04ea8c15f0b0e2e4145d6529138e0532e92751fd07be04a2180519135d386dfc19e7f12c8eb37b3e15ee81ba357680d453afab56d96299b69cb511 SHA512 b2b85035c6c60a09e903d8f6deb500e42ab8bfc2f9a5b959d0055a8e02dab3a91d5460fd5028e6634c5ef6ab034186b7155e341fa25e84b9851290708e892d19
 DIST vim-8.1.0412.tar.gz 13857501 BLAKE2B 6925184359b8b36cb546c9fcba4bb01755455aa87171ea7328ece411a5a5ced45096b8bef8561059bbff9a3ade565e0648fd18dd091d6faad0eb8a67321337a5 SHA512 3f458c039a636d7d3e398f8aa9cba4b4ae650c00038618c4776959b6feb0a1e3ac56be2912c3d85cba8e8f301661a62d71acd34a4dd75dc4dc000a94bf1b237e
+DIST vim-8.1.0648.tar.gz 14061964 BLAKE2B 79bf52d8574167471c93942904dc2b4ad5648ec365561494bbad45c779154b75b0fff1d90229516e938371f1eaa5808659cb2181b150c4c13bf8501bd9987b38 SHA512 d41676a6bb6bc442f4946ca021b2835d7ea0e54fbefe1bfc728241e1bf203cc696b707fcca6f25c877660283a790cefa4259fbd14de88fd4db7390701189c454
diff --git a/app-editors/vim/vim-8.1.0648.ebuild b/app-editors/vim/vim-8.1.0648.ebuild
new file mode 100644 (file)
index 0000000..abe19b7
--- /dev/null
@@ -0,0 +1,321 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+VIM_VERSION="8.1"
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6,3_7} )
+PYTHON_REQ_USE="threads(+)"
+USE_RUBY="ruby23 ruby24 ruby25"
+
+inherit vim-doc flag-o-matic bash-completion-r1 python-single-r1 ruby-single desktop xdg-utils gnome2-utils
+
+if [[ ${PV} == 9999* ]] ; then
+       inherit git-r3
+       EGIT_REPO_URI="https://github.com/vim/vim.git"
+else
+       SRC_URI="https://github.com/vim/vim/archive/v${PV}.tar.gz -> ${P}.tar.gz
+               https://dev.gentoo.org/~radhermit/vim/vim-8.0.0938-gentoo-patches.tar.bz2"
+       KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+fi
+
+DESCRIPTION="Vim, an improved vi-style text editor"
+HOMEPAGE="https://vim.sourceforge.io/ https://github.com/vim/vim"
+
+SLOT="0"
+LICENSE="vim"
+IUSE="X acl cscope debug gpm lua luajit minimal nls perl python racket ruby selinux tcl terminal vim-pager"
+REQUIRED_USE="
+       luajit? ( lua )
+       python? ( ${PYTHON_REQUIRED_USE} )
+"
+
+RDEPEND="
+       >=app-eselect/eselect-vi-1.1
+       >=sys-libs/ncurses-5.2-r2:0=
+       nls? ( virtual/libintl )
+       acl? ( kernel_linux? ( sys-apps/acl ) )
+       cscope? ( dev-util/cscope )
+       gpm? ( >=sys-libs/gpm-1.19.3 )
+       lua? (
+               luajit? ( dev-lang/luajit:2= )
+               !luajit? ( dev-lang/lua:0[deprecated] )
+       )
+       !minimal? (
+               ~app-editors/vim-core-${PV}
+               dev-util/ctags
+       )
+       perl? ( dev-lang/perl:= )
+       python? ( ${PYTHON_DEPS} )
+       racket? ( dev-scheme/racket )
+       ruby? ( ${RUBY_DEPS} )
+       selinux? ( sys-libs/libselinux )
+       tcl? ( dev-lang/tcl:0= )
+       X? ( x11-libs/libXt )
+"
+
+DEPEND="
+       ${RDEPEND}
+       sys-devel/autoconf
+       nls? ( sys-devel/gettext )
+"
+
+pkg_setup() {
+       # people with broken alphabets run into trouble. bug 82186.
+       unset LANG LC_ALL
+       export LC_COLLATE="C"
+
+       # Gnome sandbox silliness. bug #114475.
+       mkdir -p "${T}"/home || die "mkdir failed"
+       export HOME="${T}"/home
+
+       use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+       if [[ ${PV} != 9999* ]] ; then
+               # Gentoo patches to fix runtime issues, cross-compile errors, etc
+               eapply "${WORKDIR}"/patches/
+       fi
+
+       # Fixup a script to use awk instead of nawk
+       sed -i -e \
+               '1s|.*|#!'"${EPREFIX}"'/usr/bin/awk -f|' \
+               "${S}"/runtime/tools/mve.awk || die "mve.awk sed failed"
+
+       # Read vimrc and gvimrc from /etc/vim
+       echo '#define SYS_VIMRC_FILE "'${EPREFIX}'/etc/vim/vimrc"' \
+               >> "${S}"/src/feature.h || die "echo failed"
+       echo '#define SYS_GVIMRC_FILE "'${EPREFIX}'/etc/vim/gvimrc"' \
+               >> "${S}"/src/feature.h || die "echo failed"
+
+       # Use exuberant ctags which installs as /usr/bin/exuberant-ctags.
+       # Hopefully this pattern won't break for a while at least.
+       # This fixes bug 29398 (27 Sep 2003 agriffis)
+       sed -i -e \
+               's/\<ctags\("\| [-*.]\)/exuberant-&/g' \
+               "${S}"/runtime/doc/syntax.txt \
+               "${S}"/runtime/doc/tagsrch.txt \
+               "${S}"/runtime/doc/usr_29.txt \
+               "${S}"/runtime/menu.vim \
+               "${S}"/src/configure.ac || die 'sed failed'
+
+       # Don't be fooled by /usr/include/libc.h.  When found, vim thinks
+       # this is NeXT, but it's actually just a file in dev-libs/9libs
+       # This fixes bug 43885 (20 Mar 2004 agriffis)
+       sed -i -e \
+               's/ libc\.h / /' \
+               "${S}"/src/configure.ac || die 'sed failed'
+
+       # gcc on sparc32 has this, uhm, interesting problem with detecting EOF
+       # correctly. To avoid some really entertaining error messages about stuff
+       # which isn't even in the source file being invalid, we'll do some trickery
+       # to make the error never occur. bug 66162 (02 October 2004 ciaranm)
+       find "${S}" -name '*.c' | while read c; do
+           echo >> "$c" || die "echo failed"
+       done
+
+       # conditionally make the manpager.sh script
+       if use vim-pager; then
+               cat > "${S}"/runtime/macros/manpager.sh <<-_EOF_ || die "cat EOF failed"
+                       #!/bin/sh
+                       sed -e 's/\x1B\[[[:digit:]]\+m//g' | col -b | \\
+                                       vim \\
+                                               -c 'let no_plugin_maps = 1' \\
+                                               -c 'set nolist nomod ft=man ts=8' \\
+                                               -c 'let g:showmarks_enable=0' \\
+                                               -c 'runtime! macros/less.vim' -
+                       _EOF_
+       fi
+
+       # Try to avoid sandbox problems. Bug #114475.
+       if [[ -d "${S}"/src/po ]]; then
+               sed -i -e \
+                       '/-S check.vim/s,..VIM.,ln -s $(VIM) testvim \; ./testvim -X,' \
+                       "${S}"/src/po/Makefile || die "sed failed"
+       fi
+
+       cp -v "${S}"/src/config.mk.dist "${S}"/src/auto/config.mk || die "cp failed"
+
+       sed -i -e \
+               "s:\\\$(PERLLIB)/ExtUtils/xsubpp:${EPREFIX}/usr/bin/xsubpp:" \
+               "${S}"/src/Makefile || die 'sed for ExtUtils-ParseXS failed'
+
+       eapply_user
+}
+
+src_configure() {
+       local myconf=()
+
+       # Fix bug 37354: Disallow -funroll-all-loops on amd64
+       # Bug 57859 suggests that we want to do this for all archs
+       filter-flags -funroll-all-loops
+
+       # Fix bug 76331: -O3 causes problems, use -O2 instead. We'll do this for
+       # everyone since previous flag filtering bugs have turned out to affect
+       # multiple archs...
+       replace-flags -O3 -O2
+
+       # Fix bug 18245: Prevent "make" from the following chain:
+       # (1) Notice configure.ac is newer than auto/configure
+       # (2) Rebuild auto/configure
+       # (3) Notice auto/configure is newer than auto/config.mk
+       # (4) Run ./configure (with wrong args) to remake auto/config.mk
+       sed -i 's# auto/config\.mk:#:#' src/Makefile || die "Makefile sed failed"
+       rm src/auto/configure || die "rm failed"
+       emake -j1 -C src autoconf
+
+       # This should fix a sandbox violation (see bug 24447). The hvc
+       # things are for ppc64, see bug 86433.
+       for file in /dev/pty/s* /dev/console /dev/hvc/* /dev/hvc*; do
+               if [[ -e "${file}" ]]; then
+                       addwrite $file
+               fi
+       done
+
+       if use minimal; then
+               myconf=(
+                       --with-features=tiny
+                       --disable-nls
+                       --disable-multibyte
+                       --disable-acl
+                       --enable-gui=no
+                       --without-x
+                       --disable-darwin
+                       --disable-luainterp
+                       --disable-perlinterp
+                       --disable-pythoninterp
+                       --disable-mzschemeinterp
+                       --disable-rubyinterp
+                       --disable-selinux
+                       --disable-tclinterp
+                       --disable-gpm
+               )
+       else
+               use debug && append-flags "-DDEBUG"
+
+               myconf=(
+                       --with-features=huge
+                       --enable-multibyte
+                       $(use_enable acl)
+                       $(use_enable cscope)
+                       $(use_enable gpm)
+                       $(use_enable lua luainterp)
+                       $(usex lua "--with-lua-prefix=${EPREFIX}/usr" "")
+                       $(use_with luajit)
+                       $(use_enable nls)
+                       $(use_enable perl perlinterp)
+                       $(use_enable python pythoninterp)
+                       $(use_enable python python3interp)
+                       $(use_enable racket mzschemeinterp)
+                       $(use_enable ruby rubyinterp)
+                       $(use_enable selinux)
+                       $(use_enable tcl tclinterp)
+                       $(use_enable terminal)
+               )
+
+               # --with-features=huge forces on cscope even if we --disable it. We need
+               # to sed this out to avoid screwiness. (1 Sep 2004 ciaranm)
+               if ! use cscope; then
+                       sed -i -e \
+                               '/# define FEAT_CSCOPE/d' src/feature.h || die "sed failed"
+               fi
+
+               # don't test USE=X here ... see bug #19115
+               # but need to provide a way to link against X ... see bug #20093
+               myconf+=(
+                       --enable-gui=no
+                       --disable-darwin
+                       $(use_with X x)
+               )
+       fi
+
+       # let package manager strip binaries
+       export ac_cv_prog_STRIP="$(type -P true ) faking strip"
+
+       # keep prefix env contained within the EPREFIX
+       use prefix && myconf+=( --without-local-dir )
+
+       econf \
+               --with-modified-by=Gentoo-${PVR} \
+               "${myconf[@]}"
+}
+
+src_compile() {
+       # The following allows emake to be used
+       emake -j1 -C src auto/osdef.h objects
+
+       emake
+}
+
+src_test() {
+       einfo
+       einfo "Starting vim tests. Several error messages will be shown"
+       einfo "while the tests run. This is normal behaviour and does not"
+       einfo "indicate a fault."
+       einfo
+       ewarn "If the tests fail, your terminal may be left in a strange"
+       ewarn "state. Usually, running 'reset' will fix this."
+       einfo
+
+       # Don't let vim talk to X
+       unset DISPLAY
+
+       emake -j1 -C src/testdir nongui
+}
+
+# Call eselect vi update with --if-unset
+# to respect user's choice (bug 187449)
+eselect_vi_update() {
+       einfo "Calling eselect vi update..."
+       eselect vi update --if-unset
+       eend $?
+}
+
+src_install() {
+       local vimfiles=/usr/share/vim/vim${VIM_VERSION/.}
+
+       # Note: Do not install symlinks for 'vi', 'ex', or 'view', as these are
+       #       managed by eselect-vi
+       dobin src/vim
+       dosym vim /usr/bin/vimdiff
+       dosym vim /usr/bin/rvim
+       dosym vim /usr/bin/rview
+       if use vim-pager ; then
+               dosym ${vimfiles}/macros/less.sh /usr/bin/vimpager
+               dosym ${vimfiles}/macros/manpager.sh /usr/bin/vimmanpager
+               insinto ${vimfiles}/macros
+               doins runtime/macros/manpager.sh
+               fperms a+x ${vimfiles}/macros/manpager.sh
+       fi
+
+       domenu runtime/vim.desktop
+
+       newbashcomp "${FILESDIR}"/${PN}-completion ${PN}
+
+       # keep in sync with 'complete ... -F' list
+       bashcomp_alias vim ex vi view rvim rview vimdiff
+}
+
+pkg_postinst() {
+       # Update documentation tags (from vim-doc.eclass)
+       update_vim_helptags
+
+       # Call eselect vi update
+       eselect_vi_update
+
+       # update desktop file mime/icon caches
+       xdg_desktop_database_update
+       gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+       # Update documentation tags (from vim-doc.eclass)
+       update_vim_helptags
+
+       # Call eselect vi update
+       eselect_vi_update
+
+       # update desktop file mime/icon caches
+       xdg_desktop_database_update
+       gnome2_icon_cache_update
+}
index 0b199842bec1e96da8e1e22968b879102a2b2681..abe19b7c71abc553f00ff76c0199b4ca7098847a 100644 (file)
@@ -1,13 +1,13 @@
 # Copyright 1999-2018 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=7
+EAPI=6
 VIM_VERSION="8.1"
 PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6,3_7} )
 PYTHON_REQ_USE="threads(+)"
 USE_RUBY="ruby23 ruby24 ruby25"
 
-inherit vim-doc flag-o-matic bash-completion-r1 python-single-r1 ruby-single desktop
+inherit vim-doc flag-o-matic bash-completion-r1 python-single-r1 ruby-single desktop xdg-utils gnome2-utils
 
 if [[ ${PV} == 9999* ]] ; then
        inherit git-r3
@@ -302,6 +302,10 @@ pkg_postinst() {
 
        # Call eselect vi update
        eselect_vi_update
+
+       # update desktop file mime/icon caches
+       xdg_desktop_database_update
+       gnome2_icon_cache_update
 }
 
 pkg_postrm() {
@@ -310,4 +314,8 @@ pkg_postrm() {
 
        # Call eselect vi update
        eselect_vi_update
+
+       # update desktop file mime/icon caches
+       xdg_desktop_database_update
+       gnome2_icon_cache_update
 }