dev-lang/gnat-gpl: Fix binary install
authorTupone Alfredo <tupone@gentoo.org>
Fri, 20 Apr 2018 06:24:13 +0000 (08:24 +0200)
committerTupone Alfredo <tupone@gentoo.org>
Fri, 20 Apr 2018 06:24:13 +0000 (08:24 +0200)
Closes: https://bugs.gentoo.org/653532
Package-Manager: Portage-2.3.24, Repoman-2.3.6

dev-lang/gnat-gpl/gnat-gpl-2016.ebuild
dev-lang/gnat-gpl/gnat-gpl-2017.ebuild

index 7015061fac26b758cd09df6a40167056388f39d2..46b9e7bbbfd85345367b86d50075d68a0330b8e5 100644 (file)
@@ -88,15 +88,16 @@ pkg_setup() {
                GNATBIND="${path}/${GNATBIND}"
                CXX="${path}/${CXX}"
        fi
+}
+
+src_unpack() {
        if ! use bootstrap && [[ -z "$(type ${GNATMAKE} 2>/dev/null)" ]] ; then
                eerror "You need a gcc compiler that provides the Ada Compiler:"
                eerror "1) use gcc-config to select the right compiler or"
                eerror "2) set the bootstrap use flag"
                die "ada compiler not available"
        fi
-}
 
-src_unpack() {
        GCC_A_FAKEIT="${P}-src.tar.gz
                ${MYP}.tar.gz
                ${FSFGCC}.tar.bz2
index dde7fbf04a931b34346bb2b291433287e0243317..eeaf6193796fc3445c2d1470ce85130654af11c1 100644 (file)
@@ -70,16 +70,16 @@ pkg_setup() {
        if [[ ${gnatpath} != "." ]] ; then
                GNATMAKE="${gnatpath}/${GNATMAKE}"
        fi
+}
 
+src_unpack() {
        if ! use bootstrap && [[ -z "$(type ${GNATMAKE} 2>/dev/null)" ]] ; then
                eerror "You need a gcc compiler that provides the Ada Compiler:"
                eerror "1) use gcc-config to select the right compiler or"
                eerror "2) set the bootstrap use flag"
                die "ada compiler not available"
        fi
-}
 
-src_unpack() {
        GCC_A_FAKEIT="
                ${P}-src.tar.gz
                ${MYP}.tar.gz