dev-libs/libressl: version bump to 3.0.0
authorAnthony G. Basile <blueness@gentoo.org>
Tue, 6 Aug 2019 17:46:52 +0000 (13:46 -0400)
committerAnthony G. Basile <blueness@gentoo.org>
Tue, 6 Aug 2019 17:47:10 +0000 (13:47 -0400)
Package-Manager: Portage-2.3.69, Repoman-2.3.16
Signed-off-by: Anthony G. Basile <blueness@gentoo.org>
dev-libs/libressl/Manifest
dev-libs/libressl/libressl-3.0.0.ebuild [new file with mode: 0644]

index 6e2d9e25a205aed3c19324db9a5c80cbe121c7e3..733e24a4f32e8393baeb39844f0f4923a4d8383c 100644 (file)
@@ -2,3 +2,4 @@ DIST libressl-2.6.5.tar.gz 3225481 BLAKE2B fcdf0d8b4b68fdb6c17299f4b9897c84f51ec
 DIST libressl-2.8.3.tar.gz 3366196 BLAKE2B e32c097b31998d68a31266fbbf3624d5ab8ca716f8c53e423bcf09b3a8ab3542c92a99e259ded7b86f99b45cc199cd44791520a609f18c35d150365de5768eec SHA512 3967e08b3dc2277bf77057ea1f11148df7f96a2203cd21cf841902f2a1ec11320384a001d01fa58154d35612f7981bf89d5b1a60a2387713d5657677f76cc682
 DIST libressl-2.9.1.tar.gz 3607116 BLAKE2B a4542d7fc97bfd213162fe908e28b27d52329e2b6a5d77e0cb67d1a6732c500ca772d0c5735c9fcd036c477e6ede330305b4675bfcff9f72fd7886a781f30015 SHA512 7051911e566bb093c48a70da72c9981b870e3bf49a167ba6c934eece873084cc41221fbe3cd0c8baba268d0484070df7164e4b937854e716337540a87c214354
 DIST libressl-2.9.2.tar.gz 3607549 BLAKE2B 496e993e4f1c85167e0344afab61259d4e3f094a7e5dfac85878191070e2c196753162532efb921fab582481aeda3705fca9a2b48921cba82465192f2c1eef95 SHA512 b43e73e47c1f14da3c702ab42f29f1d67645a4fa425441337bd6c125b481ef78a40fd13e6b34dadb2af337e1c0c190cfb616186d4db9c9a743a37e594b9b8033
+DIST libressl-3.0.0.tar.gz 3620475 BLAKE2B c1dc1709e60cfbfa9907c206340262b78e1bfb991d3956dfc0a5d8d80f80b61df41059e645f9f096185724470e8466a5b7a444a575f5f09d5a0f9eb35ff3ae7e SHA512 460fa390012218262b7c148a28e6ddfc0dc3d669c4bdd37b68bfa6f50a0cb2fb81a277fb46ae0ac22673aae5b5cc4476fe96e56471a6812176bf76e9c5e10838
diff --git a/dev-libs/libressl/libressl-3.0.0.ebuild b/dev-libs/libressl/libressl-3.0.0.ebuild
new file mode 100644 (file)
index 0000000..65dfe07
--- /dev/null
@@ -0,0 +1,62 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit multilib-minimal libtool
+
+DESCRIPTION="Free version of the SSL/TLS protocol forked from OpenSSL"
+HOMEPAGE="https://www.libressl.org/"
+SRC_URI="https://ftp.openbsd.org/pub/OpenBSD/LibreSSL/${P}.tar.gz"
+
+LICENSE="ISC openssl"
+# Reflects ABI of libcrypto.so and libssl.so.  Since these can differ,
+# we'll try to use the max of either.  However, if either change between
+# versions, we have to change the subslot to trigger rebuild of consumers.
+SLOT="0/47"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="+asm static-libs test"
+REQUIRED_USE="test? ( static-libs )"
+
+RDEPEND="!dev-libs/openssl:0"
+DEPEND="${RDEPEND}"
+PDEPEND="app-misc/ca-certificates"
+
+src_prepare() {
+       touch crypto/Makefile.in
+
+       sed -i \
+               -e '/^[ \t]*CFLAGS=/s#-g ##' \
+               -e '/^[ \t]*CFLAGS=/s#-g"#"#' \
+               -e '/^[ \t]*CFLAGS=/s#-O2 ##' \
+               -e '/^[ \t]*CFLAGS=/s#-O2"#"#' \
+               -e '/^[ \t]*USER_CFLAGS=/s#-O2 ##' \
+               -e '/^[ \t]*USER_CFLAGS=/s#-O2"#"#' \
+               configure || die "fixing CFLAGS failed"
+
+       if ! use test ; then
+       sed -i \
+               -e '/^[ \t]*SUBDIRS =/s#tests##' \
+               Makefile.in || die "Removing tests failed"
+       fi
+
+       eapply "${FILESDIR}"/${PN}-2.8.3-solaris10.patch
+       eapply_user
+
+       elibtoolize  # for Solaris
+}
+
+multilib_src_configure() {
+       ECONF_SOURCE="${S}" econf \
+               $(use_enable asm) \
+               $(use_enable static-libs static)
+}
+
+multilib_src_test() {
+       emake check
+}
+
+multilib_src_install_all() {
+       einstalldocs
+       find "${D}" -name '*.la' -exec rm -f {} + || die
+}