projects
/
gentoo.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
28c81d2
)
media-libs/mesa: Explicitly limit llvm max version
author
Matt Turner
<mattst88@gentoo.org>
Fri, 3 Apr 2020 17:39:33 +0000
(10:39 -0700)
committer
Matt Turner
<mattst88@gentoo.org>
Fri, 3 Apr 2020 17:42:29 +0000
(10:42 -0700)
Closes: https://bugs.gentoo.org/712904
Signed-off-by: Matt Turner <mattst88@gentoo.org>
media-libs/mesa/mesa-9999.ebuild
patch
|
blob
|
history
diff --git
a/media-libs/mesa/mesa-9999.ebuild
b/media-libs/mesa/mesa-9999.ebuild
index f0f83ac221d1f70f43e3115f576021d00a328d1d..91f99eee5b6401062c79449e738578e21a6d4028 100644
(file)
--- a/
media-libs/mesa/mesa-9999.ebuild
+++ b/
media-libs/mesa/mesa-9999.ebuild
@@
-154,7
+154,7
@@
LLVM_DEPSTR="
sys-devel/llvm:9[${MULTILIB_USEDEP}]
sys-devel/llvm:8[${MULTILIB_USEDEP}]
)
-
sys-devel/llvm
:=[${MULTILIB_USEDEP}]
+
<sys-devel/llvm-$((LLVM_MAX_SLOT + 1))
:=[${MULTILIB_USEDEP}]
"
LLVM_DEPSTR_AMDGPU=${LLVM_DEPSTR//]/,llvm_targets_AMDGPU(-)]}
CLANG_DEPSTR=${LLVM_DEPSTR//llvm/clang}