dev-lang/php: Drop versionator for eapi7-ver
authorBrian Evans <grknight@gentoo.org>
Fri, 17 Aug 2018 03:34:17 +0000 (23:34 -0400)
committerBrian Evans <grknight@gentoo.org>
Fri, 17 Aug 2018 03:34:43 +0000 (23:34 -0400)
Package-Manager: Portage-2.3.46, Repoman-2.3.10

dev-lang/php/php-5.6.36.ebuild
dev-lang/php/php-5.6.37.ebuild
dev-lang/php/php-7.0.29.ebuild
dev-lang/php/php-7.0.30.ebuild
dev-lang/php/php-7.0.31.ebuild
dev-lang/php/php-7.1.16.ebuild
dev-lang/php/php-7.1.18.ebuild
dev-lang/php/php-7.1.20.ebuild

index fe5b563b7ea5ba2a882f49c5e8196ab481584ad4..4721afbce53e7b989ee67fb0907cc1ac5b087984 100644 (file)
@@ -3,7 +3,7 @@
 
 EAPI=6
 
-inherit autotools flag-o-matic versionator systemd
+inherit autotools flag-o-matic eapi7-ver systemd
 
 DESCRIPTION="The PHP language runtime engine"
 HOMEPAGE="https://secure.php.net/"
@@ -17,7 +17,7 @@ LICENSE="PHP-3.01
        gd? ( gd )
        unicode? ( BSD-2 LGPL-2.1 )"
 
-SLOT="$(get_version_component_range 1-2)"
+SLOT="$(ver_cut 1-2)"
 KEYWORDS="alpha amd64 arm ~arm64 ~hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
 
 # We can build the following SAPIs in the given order
@@ -174,7 +174,7 @@ REQUIRED_USE="
        sharedmem? ( !threads )
 "
 
-PHP_MV="$(get_major_version)"
+PHP_MV="$(ver_cut 1)"
 
 php_install_ini() {
        local phpsapi="${1}"
index deec25b7c9a347df14311c9ace6803992cdb8ffc..56adfd728558e624099e29489bee3e197c445c4c 100644 (file)
@@ -3,7 +3,7 @@
 
 EAPI=6
 
-inherit autotools flag-o-matic versionator systemd
+inherit autotools flag-o-matic eapi7-ver systemd
 
 DESCRIPTION="The PHP language runtime engine"
 HOMEPAGE="https://secure.php.net/"
@@ -17,7 +17,7 @@ LICENSE="PHP-3.01
        gd? ( gd )
        unicode? ( BSD-2 LGPL-2.1 )"
 
-SLOT="$(get_version_component_range 1-2)"
+SLOT="$(ver_cut 1-2)"
 KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
 
 # We can build the following SAPIs in the given order
@@ -174,7 +174,7 @@ REQUIRED_USE="
        sharedmem? ( !threads )
 "
 
-PHP_MV="$(get_major_version)"
+PHP_MV="$(ver_cut 1)"
 
 php_install_ini() {
        local phpsapi="${1}"
index 08da09b6482b363fbf4fdc0a0c848eeda6f55b0b..94a37d5d002535974eb81e58aa6aadb8d20ea2b9 100644 (file)
@@ -3,7 +3,7 @@
 
 EAPI=6
 
-inherit flag-o-matic versionator systemd
+inherit flag-o-matic eapi7-ver systemd
 
 DESCRIPTION="The PHP language runtime engine"
 HOMEPAGE="https://secure.php.net/"
@@ -17,7 +17,7 @@ LICENSE="PHP-3.01
        gd? ( gd )
        unicode? ( BSD-2 LGPL-2.1 )"
 
-SLOT="$(get_version_component_range 1-2)"
+SLOT="$(ver_cut 1-2)"
 KEYWORDS="alpha amd64 arm ~arm64 ~hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
 
 # We can build the following SAPIs in the given order
@@ -171,7 +171,7 @@ PATCHES=(
        "${FILESDIR}/php-freetype-2.9.1.patch"
 )
 
-PHP_MV="$(get_major_version)"
+PHP_MV="$(ver_cut 1)"
 
 php_install_ini() {
        local phpsapi="${1}"
index 08da09b6482b363fbf4fdc0a0c848eeda6f55b0b..94a37d5d002535974eb81e58aa6aadb8d20ea2b9 100644 (file)
@@ -3,7 +3,7 @@
 
 EAPI=6
 
-inherit flag-o-matic versionator systemd
+inherit flag-o-matic eapi7-ver systemd
 
 DESCRIPTION="The PHP language runtime engine"
 HOMEPAGE="https://secure.php.net/"
@@ -17,7 +17,7 @@ LICENSE="PHP-3.01
        gd? ( gd )
        unicode? ( BSD-2 LGPL-2.1 )"
 
-SLOT="$(get_version_component_range 1-2)"
+SLOT="$(ver_cut 1-2)"
 KEYWORDS="alpha amd64 arm ~arm64 ~hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
 
 # We can build the following SAPIs in the given order
@@ -171,7 +171,7 @@ PATCHES=(
        "${FILESDIR}/php-freetype-2.9.1.patch"
 )
 
-PHP_MV="$(get_major_version)"
+PHP_MV="$(ver_cut 1)"
 
 php_install_ini() {
        local phpsapi="${1}"
index b88f71d861d216d3241b6ece8e9ca028c514140a..aeaedb772a11a97bb9d9ce67eb1b3d4432a3ece5 100644 (file)
@@ -3,7 +3,7 @@
 
 EAPI=6
 
-inherit flag-o-matic versionator systemd
+inherit flag-o-matic eapi7-ver systemd
 
 DESCRIPTION="The PHP language runtime engine"
 HOMEPAGE="https://secure.php.net/"
@@ -17,7 +17,7 @@ LICENSE="PHP-3.01
        gd? ( gd )
        unicode? ( BSD-2 LGPL-2.1 )"
 
-SLOT="$(get_version_component_range 1-2)"
+SLOT="$(ver_cut 1-2)"
 KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
 
 # We can build the following SAPIs in the given order
@@ -171,7 +171,7 @@ PATCHES=(
        "${FILESDIR}/php-freetype-2.9.1.patch"
 )
 
-PHP_MV="$(get_major_version)"
+PHP_MV="$(ver_cut 1)"
 
 php_install_ini() {
        local phpsapi="${1}"
index da637b55abbd6aa905b19b5258aacda077ac1f6f..4acba555659f8ba8f071aab04e4639a950babddc 100644 (file)
@@ -3,7 +3,7 @@
 
 EAPI=6
 
-inherit flag-o-matic versionator systemd
+inherit flag-o-matic eapi7-ver systemd
 
 DESCRIPTION="The PHP language runtime engine"
 HOMEPAGE="https://secure.php.net/"
@@ -17,7 +17,7 @@ LICENSE="PHP-3.01
        gd? ( gd )
        unicode? ( BSD-2 LGPL-2.1 )"
 
-SLOT="$(get_version_component_range 1-2)"
+SLOT="$(ver_cut 1-2)"
 KEYWORDS="alpha amd64 arm ~arm64 ~hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
 
 # We can build the following SAPIs in the given order
@@ -153,7 +153,7 @@ PATCHES=(
        "${FILESDIR}/php-freetype-2.9.1.patch"
 )
 
-PHP_MV="$(get_major_version)"
+PHP_MV="$(ver_cut 1)"
 
 php_install_ini() {
        local phpsapi="${1}"
index 9a6345b2fbb4f0c0c12831f3c74f47c155e91d92..a9061a4a930f32eba872704e131d0278f2840ed9 100644 (file)
@@ -3,7 +3,7 @@
 
 EAPI=6
 
-inherit flag-o-matic versionator systemd
+inherit flag-o-matic eapi7-ver systemd
 
 DESCRIPTION="The PHP language runtime engine"
 HOMEPAGE="https://secure.php.net/"
@@ -17,7 +17,7 @@ LICENSE="PHP-3.01
        gd? ( gd )
        unicode? ( BSD-2 LGPL-2.1 )"
 
-SLOT="$(get_version_component_range 1-2)"
+SLOT="$(ver_cut 1-2)"
 KEYWORDS="alpha amd64 arm ~arm64 ~hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
 
 # We can build the following SAPIs in the given order
@@ -151,7 +151,7 @@ PATCHES=(
        "${FILESDIR}/php-freetype-2.9.1.patch"
 )
 
-PHP_MV="$(get_major_version)"
+PHP_MV="$(ver_cut 1)"
 
 php_install_ini() {
        local phpsapi="${1}"
index d649e1715b3a32a048456d62254890849a96a024..46badcaed5fed245e4a84ed6247ffbc7ef91922a 100644 (file)
@@ -3,7 +3,7 @@
 
 EAPI=6
 
-inherit flag-o-matic versionator systemd
+inherit flag-o-matic eapi7-ver systemd
 
 DESCRIPTION="The PHP language runtime engine"
 HOMEPAGE="https://secure.php.net/"
@@ -17,7 +17,7 @@ LICENSE="PHP-3.01
        gd? ( gd )
        unicode? ( BSD-2 LGPL-2.1 )"
 
-SLOT="$(get_version_component_range 1-2)"
+SLOT="$(ver_cut 1-2)"
 KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
 
 # We can build the following SAPIs in the given order
@@ -148,7 +148,7 @@ PATCHES=(
        "${FILESDIR}/php-freetype-2.9.1.patch"
 )
 
-PHP_MV="$(get_major_version)"
+PHP_MV="$(ver_cut 1)"
 
 php_install_ini() {
        local phpsapi="${1}"