dev-ros/test_rosservice: Bump to 1.15.4.
authorAlexis Ballier <aballier@gentoo.org>
Wed, 13 May 2020 11:26:08 +0000 (13:26 +0200)
committerAlexis Ballier <aballier@gentoo.org>
Wed, 13 May 2020 14:07:13 +0000 (16:07 +0200)
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Alexis Ballier <aballier@gentoo.org>
dev-ros/test_rosservice/Manifest
dev-ros/test_rosservice/test_rosservice-1.15.4.ebuild [new file with mode: 0644]

index 3d0a1ebaa18a78c849f391f33420544d725d7a43..61884545d536f94f230a49b791c5f242a79fd6df 100644 (file)
@@ -1 +1,2 @@
 DIST ros_comm-1.14.3.tar.gz 1045287 BLAKE2B c079983aa730e70028d1bf2c365d01d99ce09ced0c0f6443b18f9d0fb83715f6af4b313d6db4eb99dcc10052c81fa3e6560e7b3591b2fbe14b9ec20fac24babe SHA512 52df24f10f476697ee6fa340da354b45431f35018a25e2674dc9306f175929a4b0368753503ea143f87aeb4945a2e67c37f83d833f54b53f9a76a81022c280a3
+DIST ros_comm-1.15.4.tar.gz 1071246 BLAKE2B 57867c192bfd48f3a0534762808c668031081a6155510879e68f9618226b9c5eff0d5fc9ec0e7ec8d0cc1f0d74794a4e55151036275ae6fc5bb613cc42137ddc SHA512 f92233cbf5ee97832023545730d3e756dfa08507072c074ac3e0763db1c2c2ab9fcbb0c90995a0c5d43f0ddc2ee528c185173a664b19abe4f8159aa3f3cb20dc
diff --git a/dev-ros/test_rosservice/test_rosservice-1.15.4.ebuild b/dev-ros/test_rosservice/test_rosservice-1.15.4.ebuild
new file mode 100644 (file)
index 0000000..507361e
--- /dev/null
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=test/${PN}
+CATKIN_HAS_MESSAGES=yes
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs"
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Unit tests for rospy"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+       dev-ros/rostest[${PYTHON_USEDEP}]
+       dev-ros/std_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+       test? (
+               dev-ros/test_rosmaster[${PYTHON_USEDEP}]
+               dev-ros/rospy[${PYTHON_USEDEP}]
+               dev-ros/rostest[${PYTHON_USEDEP}]
+               dev-python/nose[${PYTHON_USEDEP}]
+       )"