app-admin/conky: Version bump to conky-1.11.4.
authorDaniel Pielmeier <billie@gentoo.org>
Sat, 6 Jul 2019 09:01:58 +0000 (11:01 +0200)
committerDaniel Pielmeier <billie@gentoo.org>
Sat, 6 Jul 2019 09:04:18 +0000 (11:04 +0200)
This fixes bugs #688548 and #686706.

Signed-off-by: Daniel Pielmeier <billie@gentoo.org>
Package-Manager: Portage-2.3.66, Repoman-2.3.11

app-admin/conky/Manifest
app-admin/conky/conky-1.11.4.ebuild [new file with mode: 0644]
app-admin/conky/metadata.xml

index 0f79691cc753fd3b5ebe0d5138e8e23532bcd00b..060de8983edbb66f1ed810779fa5507d783de5ae 100644 (file)
@@ -1 +1,2 @@
 DIST conky-1.10.8.tar.gz 373075 BLAKE2B 749d8bb37557c1eeb8b07955bbd45704fadb41995fad8380dd89afdf7b0c9dce02d19692691e3ef1857d849c05eae1b2fdf20243460d767199a681aeb9e87746 SHA512 743b1d17db4ae654c7a319fe9157e9ebc5eb4ae0462a1f7269332d379e8bdd1dbfecc3ab6f46c8b5176b7e40918301649ac3ee883a84dc4fc8d766abbac6585a
+DIST conky-1.11.4.tar.gz 2400814 BLAKE2B ad12ade96de5ed3575eba3d8a6e06cb8d30ed686e002f36c3a52a1d4351379546bcea2237792929de36d8c0c402eda977a8c0b5b36a0878fe001056d8d2c34b7 SHA512 191ffe4a50a8876a658163c83a45f722f07ca6a0b86ea3ebad369d58f4c2bb798e8afaef6c0643bcca90de546a7f3de4acf9d2e4b4a2b6366bf42de0ccaade3d
diff --git a/app-admin/conky/conky-1.11.4.ebuild b/app-admin/conky/conky-1.11.4.ebuild
new file mode 100644 (file)
index 0000000..a52ce08
--- /dev/null
@@ -0,0 +1,184 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils linux-info readme.gentoo-r1 xdg
+
+DESCRIPTION="An advanced, highly configurable system monitor for X"
+HOMEPAGE="https://github.com/brndnmtthws/conky"
+SRC_URI="https://github.com/brndnmtthws/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3 BSD LGPL-2.1 MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ppc ~ppc64 ~sparc ~x86"
+IUSE="apcupsd bundled-toluapp cmus curl doc hddtemp ical iconv imlib iostats
+       ipv6 irc lua-cairo lua-imlib lua-rsvg math moc mpd mysql nano-syntax
+       ncurses nvidia +portmon pulseaudio rss systemd thinkpad truetype
+       vim-syntax weather-metar webserver wifi X xmms2"
+
+COMMON_DEPEND="
+       X? (
+               x11-libs/libX11
+               x11-libs/libXdamage
+               x11-libs/libXinerama
+               x11-libs/libXfixes
+               x11-libs/libXext
+       )
+       cmus? ( media-sound/cmus )
+       curl? ( net-misc/curl )
+       ical? ( dev-libs/libical:= )
+       iconv? ( virtual/libiconv )
+       imlib? ( media-libs/imlib2[X] )
+       irc? ( net-libs/libircclient )
+       lua-cairo? ( x11-libs/cairo[X] )
+       lua-imlib? ( media-libs/imlib2[X] )
+       lua-rsvg? ( gnome-base/librsvg )
+       mysql? ( dev-db/mysql-connector-c )
+       ncurses? ( sys-libs/ncurses:= )
+       nvidia? ( x11-drivers/nvidia-drivers[tools,static-libs] )
+       pulseaudio? ( media-sound/pulseaudio )
+       rss? ( dev-libs/libxml2 net-misc/curl dev-libs/glib:2 )
+       systemd? ( sys-apps/systemd )
+       truetype? ( x11-libs/libXft >=media-libs/freetype-2 )
+       wifi? ( net-wireless/wireless-tools )
+       weather-metar? ( net-misc/curl )
+       webserver? ( net-libs/libmicrohttpd )
+       xmms2? ( media-sound/xmms2 )
+       || ( dev-lang/lua:5.3 dev-lang/lua:5.2 )
+"
+RDEPEND="
+       ${COMMON_DEPEND}
+       apcupsd? ( sys-power/apcupsd )
+       hddtemp? ( app-admin/hddtemp )
+       moc? ( media-sound/moc )
+       nano-syntax? ( app-editors/nano )
+       vim-syntax? ( || ( app-editors/vim app-editors/gvim ) )
+"
+DEPEND="
+       ${COMMON_DEPEND}
+       doc? ( app-text/docbook2X dev-libs/libxslt )
+"
+
+REQUIRED_USE="
+       imlib? ( X )
+       nvidia? ( X )
+       truetype? ( X )
+       lua-cairo? ( X  bundled-toluapp )
+       lua-imlib? ( X  bundled-toluapp )
+       lua-rsvg? ( X  bundled-toluapp )
+"
+
+CONFIG_CHECK=~IPV6
+
+DOCS=( README.md AUTHORS )
+
+DISABLE_AUTOFORMATTING="yes"
+DOC_CONTENTS="You can find sample configurations at ${ROOT}/usr/share/doc/${PF}.
+To customize, copy to \${XDG_CONFIG_HOME}/conky/conky.conf
+and edit it to your liking.
+
+There are pretty html docs available at the conky homepage
+or in ${ROOT}/usr/share/doc/${PF}/html when built with USE=doc.
+
+Also see https://wiki.gentoo.org/wiki/Conky/HOWTO"
+
+pkg_setup() {
+       use ipv6 && linux-info_pkg_setup
+}
+
+src_prepare() {
+       cmake-utils_src_prepare
+
+       xdg_environment_reset
+
+       sed -i -e "s|find_program(APP_MAN man)|set(APP_MAN $(which man) CACHE FILEPATH MAN_BINARY)|" \
+               cmake/ConkyPlatformChecks.cmake || die
+}
+
+src_configure() {
+       local mycmakeargs
+
+       if use X; then
+               mycmakeargs=(
+                       -DBUILD_ARGB=ON
+                       -DBUILD_X11=ON
+                       -DBUILD_XDAMAGE=ON
+                       -DBUILD_XDBE=ON
+                       -DBUILD_XINERAMA=ON
+                       -DBUILD_XSHAPE=ON
+                       -DOWN_WINDOW=ON
+               )
+       else
+               mycmakeargs=(
+                       -DBUILD_X11=OFF
+               )
+       fi
+
+       mycmakeargs+=(
+               -DBUILD_APCUPSD=$(usex apcupsd)
+               -DBUILD_AUDACIOUS=OFF
+               -DBUILD_BUILTIN_CONFIG=ON
+               -DBUILD_CMUS=$(usex cmus)
+               -DBUILD_CURL=$(usex curl)
+               -DBUILD_DOCS=$(usex doc)
+               -DBUILD_HDDTEMP=$(usex hddtemp)
+               -DBUILD_HTTP=$(usex webserver)
+               -DBUILD_I18N=ON
+               -DBUILD_IBM=$(usex thinkpad)
+               -DBUILD_ICAL=$(usex ical)
+               -DBUILD_ICONV=$(usex iconv)
+               -DBUILD_IMLIB2=$(usex imlib)
+               -DBUILD_IOSTATS=$(usex iostats)
+               -DBUILD_IPV6=$(usex ipv6)
+               -DBUILD_IRC=$(usex irc)
+               -DBUILD_JOURNAL=$(usex systemd)
+               -DBUILD_LUA_CAIRO=$(usex lua-cairo)
+               -DBUILD_LUA_IMLIB2=$(usex lua-imlib)
+               -DBUILD_LUA_RSVG=$(usex lua-rsvg)
+               -DBUILD_MATH=$(usex math)
+               -DBUILD_MOC=$(usex moc)
+               -DBUILD_MPD=$(usex mpd)
+               -DBUILD_MYSQL=$(usex mysql)
+               -DBUILD_NCURSES=$(usex ncurses)
+               -DBUILD_NVIDIA=$(usex nvidia)
+               -DBUILD_OLD_CONFIG=ON
+               -DBUILD_PORT_MONITORS=$(usex portmon)
+               -DBUILD_PULSEAUDIO=$(usex pulseaudio)
+               -DBUILD_RSS=$(usex rss)
+               -DBUILD_WEATHER_METAR=$(usex weather-metar)
+               -DBUILD_WLAN=$(usex wifi)
+               -DBUILD_XFT=$(usex truetype)
+               -DBUILD_XMMS2=$(usex xmms2)
+               -DDOC_PATH=/usr/share/doc/${PF}
+               -DMAINTAINER_MODE=OFF
+               -DRELEASE=ON
+       )
+
+       cmake-utils_src_configure
+}
+
+src_install() {
+       cmake-utils_src_install
+
+       if use vim-syntax; then
+               insinto /usr/share/vim/vimfiles/ftdetect
+               doins "${S}"/extras/vim/ftdetect/conkyrc.vim
+
+               insinto /usr/share/vim/vimfiles/syntax
+               doins "${S}"/extras/vim/syntax/conkyrc.vim
+       fi
+
+       if use nano-syntax; then
+               insinto /usr/share/nano/
+               doins "${S}"/extras/nano/conky.nanorc
+       fi
+
+       readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+       readme.gentoo_print_elog
+
+       xdg_pkg_postinst
+}
index c06ab79fa44a8bedfef4e71442757c08fb8f7a2c..b3835daf404179bb2937d2e09b330b8d78082890 100644 (file)
@@ -16,6 +16,7 @@
        <longdescription>Conky is a system monitor that sits in the corner of your desktop. It is a fork of Torsmo that is actually maintained.</longdescription>
        <use>
                <flag name="apcupsd">Enable support for <pkg>sys-power/apcupsd</pkg></flag>
+               <flag name="bundled-toluapp">Enable support for bundled toluapp. This only makes sense in combination with the lua-* flags</flag>
                <flag name="cmus">Enable monitoring of music played by <pkg>media-sound/cmus</pkg></flag>
                <flag name="eve">Enable support for the eve-online skill monitor</flag>
                <flag name="ical">Enable support for events from iCalendar (RFC 5545) files using <pkg>dev-libs/libical</pkg></flag>