media-libs/grilo: bump to 0.3.9
authorMart Raudsepp <leio@gentoo.org>
Sun, 25 Aug 2019 16:30:13 +0000 (19:30 +0300)
committerMart Raudsepp <leio@gentoo.org>
Sun, 25 Aug 2019 16:46:32 +0000 (19:46 +0300)
Package-Manager: Portage-2.3.62, Repoman-2.3.12
Signed-off-by: Mart Raudsepp <leio@gentoo.org>
media-libs/grilo/Manifest
media-libs/grilo/grilo-0.3.9.ebuild [new file with mode: 0644]

index 73f842d226c1af16aa1fd92151e8c919c2e0de17..276c3d61ab9739dd87c1822a9595030d7e68cb07 100644 (file)
@@ -1 +1,2 @@
 DIST grilo-0.3.7.tar.xz 232544 BLAKE2B 2d1f7942b09808bb5e09040b4a633a6bd354220ba1369d31ff6160c12ab15c1e2642617ae7f35c8320d7a5842736d8714c6e7dc7f3cb0651d841b6513633f5c9 SHA512 82c41d63edc23c056e189a73b0de87db342bba575d42efeda78ed4bf78fb8994111a2e9457e6f2453045b9b7b2d171b9e89d71c3a107cfa06af24644d9cb71df
+DIST grilo-0.3.9.tar.xz 233616 BLAKE2B c22b868d5bcb6731024b212d6bc1502b493950e363127202ded0ed80f3e937bf78062ba6f2803e29f686ff8cfc521147e69b8f4a7b33060d81e30f34a231e37b SHA512 250596f277ea76d8f6a071fb0e48dd7ea735a534f48a4f2e3f69f7c62a2b5b4c995714a8435ffa9107345e86bba5b21fc136cc47b956f461723a00d0e6ede9bf
diff --git a/media-libs/grilo/grilo-0.3.9.ebuild b/media-libs/grilo/grilo-0.3.9.ebuild
new file mode 100644 (file)
index 0000000..f07a46d
--- /dev/null
@@ -0,0 +1,75 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7} )
+VALA_USE_DEPEND="vapigen"
+
+inherit gnome.org meson python-any-r1 vala xdg
+
+DESCRIPTION="A framework for easy media discovery and browsing"
+HOMEPAGE="https://wiki.gnome.org/Projects/Grilo"
+
+LICENSE="LGPL-2.1+"
+SLOT="0.3/0" # subslot is libgrilo-0.3 soname suffix
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+IUSE="gtk gtk-doc +introspection +network +playlist test vala"
+REQUIRED_USE="vala? ( introspection )"
+RESTRICT="!test? ( test )"
+
+# oauth could be optional if meson is patched - used for flickr oauth in grilo-test-ui tool
+RDEPEND="
+       >=dev-libs/glib-2.44:2
+       dev-libs/libxml2:2
+       network? ( >=net-libs/libsoup-2.41.3:2.4[introspection?] )
+       playlist? ( >=dev-libs/totem-pl-parser-3.4.1 )
+       introspection? ( >=dev-libs/gobject-introspection-1.54:= )
+
+       gtk? (
+               net-libs/liboauth
+               >=x11-libs/gtk+-3.14:3 )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+       dev-util/glib-utils
+       >=sys-devel/gettext-0.19.8
+       virtual/pkgconfig
+       gtk-doc? (
+               >=dev-util/gtk-doc-1.10
+               app-text/docbook-xml-dtd:4.3 )
+       ${PYTHON_DEPS}
+       test? ( sys-apps/dbus )
+       vala? ( $(vala_depend) )
+"
+
+src_prepare() {
+       sed -i -e "s:'GETTEXT_PACKAGE', meson.project_name():'GETTEXT_PACKAGE', 'grilo-${SLOT%/*}':" meson.build || die
+       sed -i -e "s:meson.project_name():'grilo-${SLOT%/*}':" po/meson.build || die
+       sed -i -e "s:'grilo':'grilo-${SLOT%/*}':" doc/grilo/meson.build || die
+
+       # Drop explicit unversioned vapigen check
+       sed -i -e "/vapigen.*=.*find_program/d" meson.build || die
+
+       # Don't build examples; they get embedded in gtk-doc, thus we don't install the sources with USE=examples either
+       sed -i -e "/subdir('examples')/d" meson.build || die
+
+       xdg_src_prepare
+       use vala && vala_src_prepare
+}
+
+src_configure() {
+       local emesonargs=(
+               $(meson_use network enable-grl-net)
+               $(meson_use playlist enable-grl-pls)
+               $(meson_use gtk-doc enable-gtk-doc)
+               $(meson_use introspection enable-introspection)
+               $(meson_use gtk enable-test-ui)
+               $(meson_use vala enable-vala)
+       )
+       meson_src_configure
+}
+
+src_test() {
+       dbus-run-session meson test -C "${BUILD_DIR}" || die
+}