Version bump. Clean up old versions.
authorPatrick McLean <chutzpah@gentoo.org>
Wed, 13 Dec 2006 15:22:32 +0000 (15:22 +0000)
committerPatrick McLean <chutzpah@gentoo.org>
Wed, 13 Dec 2006 15:22:32 +0000 (15:22 +0000)
Package-Manager: portage-2.1.2_rc3-r2

sys-fs/ntfs3g/ChangeLog
sys-fs/ntfs3g/files/digest-ntfs3g-0.20061212 [new file with mode: 0644]
sys-fs/ntfs3g/ntfs3g-0.20061212.ebuild [new file with mode: 0644]

index ccde49bcc24f88c7e670097e851be8cdd4466175..3e1af5f61f530e7439fa170fe3b5d95fe067f833 100644 (file)
@@ -1,6 +1,12 @@
 # ChangeLog for sys-fs/ntfs3g
 # Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/ntfs3g/ChangeLog,v 1.16 2006/11/20 16:43:02 chutzpah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/ntfs3g/ChangeLog,v 1.17 2006/12/13 15:22:32 chutzpah Exp $
+
+*ntfs3g-0.20061212 (13 Dec 2006)
+
+  13 Dec 2006; Patrick McLean <chutzpah@gentoo.org>
+  +ntfs3g-0.20061212.ebuild:
+  Version bump. Clean up old versions.
 
 *ntfs3g-0.20061115-r1 (20 Nov 2006)
 
diff --git a/sys-fs/ntfs3g/files/digest-ntfs3g-0.20061212 b/sys-fs/ntfs3g/files/digest-ntfs3g-0.20061212
new file mode 100644 (file)
index 0000000..cfadf5f
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 272ff4191b3ec79ef8187da8bc7ffda1 ntfs-3g-0.20061212-BETA.tgz 560660
+RMD160 abc461c153aec92a4403480c553da46f72191305 ntfs-3g-0.20061212-BETA.tgz 560660
+SHA256 25a10368a17a139e7b4d68e6a135da4725a4da85eab567a2ff3e3e6dbed6caa0 ntfs-3g-0.20061212-BETA.tgz 560660
diff --git a/sys-fs/ntfs3g/ntfs3g-0.20061212.ebuild b/sys-fs/ntfs3g/ntfs3g-0.20061212.ebuild
new file mode 100644 (file)
index 0000000..a9c20ee
--- /dev/null
@@ -0,0 +1,54 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/ntfs3g/ntfs3g-0.20061212.ebuild,v 1.1 2006/12/13 15:22:32 chutzpah Exp $
+
+inherit linux-info
+
+MY_PN="${PN/3g/-3g}"
+MY_PV="${PV}-BETA"
+MY_P="${MY_PN}-${MY_PV}"
+
+DESCRIPTION="Open source read-write NTFS driver that runs under FUSE"
+HOMEPAGE="http://www.ntfs-3g.org"
+SRC_URI="http://www.ntfs-3g.org/${MY_P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=sys-fs/fuse-2.6.0"
+DEPEND="${RDEPEND}
+       dev-util/pkgconfig"
+
+S="${WORKDIR}/${MY_P}"
+
+CONFIG_CHECK="!FUSE_FS"
+ERR=" ${BAD}*${NORMAL}  "
+ERROR_FUSE_FS="For this version of ntfs-3g to work properly, you need to use the
+$ERR kernel module included in the package, not the kernel version. To do this
+$ERR remove FUSE from your kernel, recompile it then remerge FUSE.
+$ERR
+$ERR    emerge -a1 sys-fs/fuse
+$ERR
+$ERR You will need to reboot if you had FUSE in your kernel, if it was a module, this
+$ERR should be enough:
+$ERR
+$ERR    modprobe -r fuse
+$ERR    modprobe fuse
+$ERR
+$ERR If either of these commands have an error, you will need to reboot.
+$ERR"
+
+src_unpack() {
+       unpack ${A}
+       cd "${S}"
+
+       # default makefile calls ldconfig
+       sed -ie '/ldconfig$/ d' src/Makefile.*
+}
+
+src_install() {
+       make DESTDIR="${D}" install || die "install failed"
+       dodoc AUTHORS ChangeLog CREDITS NEWS README
+}