Use $CFLAGS instead of hardcoded -O3 --ffast-math (bug #136885).
authorAlexandre Buisse <nattfodd@gentoo.org>
Thu, 15 Jun 2006 17:41:25 +0000 (17:41 +0000)
committerAlexandre Buisse <nattfodd@gentoo.org>
Thu, 15 Jun 2006 17:41:25 +0000 (17:41 +0000)
Package-Manager: portage-2.1

media-gfx/ufraw/ChangeLog
media-gfx/ufraw/files/digest-ufraw-0.8.1-r1 [new file with mode: 0644]
media-gfx/ufraw/files/ufraw-cflags.patch [new file with mode: 0644]
media-gfx/ufraw/ufraw-0.8.1-r1.ebuild [new file with mode: 0644]

index e4d405da8286c8494d19c3030834dd1b45c1051f..c648c6a2d02f58a080f18bbee1a6ac7b61a7ed1d 100644 (file)
@@ -1,6 +1,12 @@
 # ChangeLog for media-gfx/ufraw
 # Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/ufraw/ChangeLog,v 1.6 2006/05/14 05:51:24 nattfodd Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/ufraw/ChangeLog,v 1.7 2006/06/15 17:41:25 nattfodd Exp $
+
+*ufraw-0.8.1-r1 (15 Jun 2006)
+
+  15 Jun 2006; Alexandre Buisse <nattfodd@gentoo.org>
+  +files/ufraw-cflags.patch, -ufraw-0.8.1.ebuild, +ufraw-0.8.1-r1.ebuild:
+  Use $CFLAGS instead of hardcoded -O3 --ffast-math (bug #136885).
 
 *ufraw-0.8.1 (14 May 2006)
 
diff --git a/media-gfx/ufraw/files/digest-ufraw-0.8.1-r1 b/media-gfx/ufraw/files/digest-ufraw-0.8.1-r1
new file mode 100644 (file)
index 0000000..900ace9
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 d79a377a5bd194c10a6db566c9e50d5c ufraw-0.8.1.tar.gz 317793
+RMD160 bb9cdac410523d8a99539b864f27824d5b5b9208 ufraw-0.8.1.tar.gz 317793
+SHA256 9dc13e33ac9146877c3dd761c44db0b1d2302f5ff8fc017f9b92d0281673f2c6 ufraw-0.8.1.tar.gz 317793
diff --git a/media-gfx/ufraw/files/ufraw-cflags.patch b/media-gfx/ufraw/files/ufraw-cflags.patch
new file mode 100644 (file)
index 0000000..d406eb7
--- /dev/null
@@ -0,0 +1,18 @@
+--- ufraw-0.8.1/configure.ac.old       2006-06-15 19:30:30.000000000 +0200
++++ ufraw-0.8.1/configure.ac   2006-06-15 19:30:54.000000000 +0200
+@@ -32,10 +32,11 @@
+     AC_MSG_ERROR([size of double must be 8])
+ fi
+-UFRAW_CFLAGS="-ffast-math -fomit-frame-pointer"
+-if test "x$GCC" = "xyes"; then
+-    UFRAW_CFLAGS="$UFRAW_CFLAGS -W -Wall -O3"
+-fi
++dnl UFRAW_CFLAGS="-ffast-math -fomit-frame-pointer"
++dnl if test "x$GCC" = "xyes"; then
++dnl     UFRAW_CFLAGS="$UFRAW_CFLAGS -W -Wall -O3"
++dnl fi
++UFRAW_CFLAGS="$CFLAGS"
+ # windows will require some special attention
+ case $host_os in
diff --git a/media-gfx/ufraw/ufraw-0.8.1-r1.ebuild b/media-gfx/ufraw/ufraw-0.8.1-r1.ebuild
new file mode 100644 (file)
index 0000000..abdf723
--- /dev/null
@@ -0,0 +1,42 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/ufraw/ufraw-0.8.1-r1.ebuild,v 1.1 2006/06/15 17:41:25 nattfodd Exp $
+
+inherit eutils autotools
+
+DESCRIPTION="RAW Image format viewer and GIMP plugin"
+HOMEPAGE="http://ufraw.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="gimp exif" # jpeg tiff"
+
+
+#should but not
+DEPEND=">=x11-libs/gtk+-2.4.0
+       gimp? ( >=media-gfx/gimp-2.0 )
+       exif? ( >=media-libs/libexif-0.6.13 )
+       media-libs/jpeg
+       media-libs/tiff
+       >=media-libs/lcms-1.13"
+
+src_unpack() {
+       unpack ${A}
+       cd "${S}"
+       epatch ${FILESDIR}/${PN}-cflags.patch
+       eautoreconf || die "failed running autoreconf"
+}
+
+
+src_compile() {
+       econf `use_enable gimp` \
+               `use_with exif libexif` || die "configure failed"
+       emake || die "emake failed"
+}
+
+
+src_install() {
+       make DESTDIR="${D}" install || die
+}