dev-python/tlslite: Version Bump
authorJustin Lecher <jlec@gentoo.org>
Sun, 13 Sep 2015 08:51:41 +0000 (10:51 +0200)
committerJustin Lecher <jlec@gentoo.org>
Sun, 13 Sep 2015 08:52:14 +0000 (10:52 +0200)
Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=560278

Package-Manager: portage-2.2.20.1
Signed-off-by: Justin Lecher <jlec@gentoo.org>
dev-python/tlslite/Manifest
dev-python/tlslite/tlslite-0.4.3-r1.ebuild
dev-python/tlslite/tlslite-0.4.8.ebuild [new file with mode: 0644]

index 7b6d1a69e098ec8db9da23745ecfcaa4e3dab5fc..c2db3dfb38bff323addd673a2f70f294c5da9ce5 100644 (file)
@@ -1 +1,2 @@
 DIST tlslite-0.4.3.tar.gz 562090 SHA256 6a67d8a0bec66183719c19c91f383bc1555545055aae4498af2e91fe9d79f813 SHA512 d1f451ebc2f7bd4d5436f1ca8ecfdbaa403f3dbbae9f9ac3900131e5d168e3267e22fcf23d85f87457f06468997cb01a51683d028a67fde58820b15f97689a0c WHIRLPOOL 555f2659f0bb5080519edd5f4325953e13109367ef21e1595816ab4f3956233bb541940f65f2cfa95c041b7f2cc080b8c4ee10719be79edfa11076a2c834fff6
+DIST tlslite-0.4.8.tar.gz 563048 SHA256 d9b447048a322c70df800f540ab577c93ecf20de52c0a02c8621176e4733bdbb SHA512 bdb42d005b7444667badc6febd38f5b74878c09218b418844c255920f0e6272f55f62b4ea21953953935f73e02657fce9874b44f73499267cf713ddbcd3d6a44 WHIRLPOOL 0804742e528e6ce9d67afed78fe42c4f0a42cdfc221bf36d37e4f4f5fce828323da10f7bec3e68b2fdcf4d13d2fa100364e83e61fbcfc5cf86d3aeb1f51d75df
index 56c231a2ef097e06708631260192241844b7cc6a..a23e46330ebb301bb9e6d211329a1080b818f757 100644 (file)
@@ -4,13 +4,13 @@
 
 EAPI=5
 
-PYTHON_COMPAT=( python2_7 pypy )
+PYTHON_COMPAT=( python2_7 )
 
-inherit distutils-r1
+inherit distutils-r1 eutils
 
 DESCRIPTION="TLS Lite is a free python library that implements SSL 3.0 and TLS 1.0/1.1"
-HOMEPAGE="http://trevp.net/tlslite/ https://pypi.python.org/pypi/tlslite"
-SRC_URI="https://github.com/trevp/tlslite/downloads/${P}.tar.gz"
+HOMEPAGE="http://trevp.net/tlslite/ https://pypi.python.org/pypi/tlslite https://github.com/trevp/tlslite"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
 
 LICENSE="BSD public-domain"
 SLOT="0"
@@ -19,12 +19,12 @@ KEYWORDS="amd64 x86"
 IUSE="doc gmp"
 RESTRICT="test"
 
-DEPEND=">=dev-libs/cryptlib-3.3.3[python,${PYTHON_USEDEP}]
+DEPEND="
+       >=dev-libs/cryptlib-3.3.3[python,${PYTHON_USEDEP}]
        || (
                dev-python/m2crypto[${PYTHON_USEDEP}]
                dev-python/pycrypto[${PYTHON_USEDEP}]
-       )
-       gmp? ( dev-python/gmpy[${PYTHON_USEDEP}] )"
+       )"
 RDEPEND="${DEPEND}"
 
 # Tests still hang
diff --git a/dev-python/tlslite/tlslite-0.4.8.ebuild b/dev-python/tlslite/tlslite-0.4.8.ebuild
new file mode 100644 (file)
index 0000000..ec5c394
--- /dev/null
@@ -0,0 +1,45 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="TLS Lite is a free python library that implements SSL 3.0 and TLS 1.0/1.1"
+HOMEPAGE="http://trevp.net/tlslite/ https://pypi.python.org/pypi/tlslite https://github.com/trevp/tlslite"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+#Refrain for now setting IUSE test and deps of test given test restricted.
+IUSE="doc"
+
+DEPEND="
+       >=dev-libs/cryptlib-3.3.3[python,${PYTHON_USEDEP}]
+       || (
+               dev-python/m2crypto[${PYTHON_USEDEP}]
+               dev-python/pycrypto[${PYTHON_USEDEP}]
+       )"
+RDEPEND="${DEPEND}"
+
+RESTRICT="test"
+
+# Tests still hang
+python_test() {
+       cd tests || die
+       "${PYTHON}" "${S}"/tests/tlstest.py client localhost:4443 . || die
+       "${PYTHON}" "${S}"/tests/tlstest.py server localhost:4442 . || die
+}
+
+python_install_all(){
+       use doc && HTML_DOCS=( docs/. )
+       distutils-r1_python_install_all
+}
+
+pkg_postinst() {
+       optfeature "GMP support" dev-python/gmpy
+}