media-libs/mesa: Add REQUIRED_USE For USE=d3d9
authorMatt Turner <mattst88@gentoo.org>
Sat, 10 Nov 2018 18:33:36 +0000 (10:33 -0800)
committerMatt Turner <mattst88@gentoo.org>
Sat, 10 Nov 2018 18:46:56 +0000 (10:46 -0800)
The new Meson build requires a suitable driver to be enabled, and
ignoring the d3d9 USE flag isn't safe since WINE has a dependency on
mesa[d3d9].

Closes: https://bugs.gentoo.org/670737
Signed-off-by: Matt Turner <mattst88@gentoo.org>
media-libs/mesa/mesa-18.2.4.ebuild
media-libs/mesa/mesa-9999.ebuild

index 013ed5b1e1f3b97c643332b2536da43fe1082ca1..661f4153d490069b4d83d23ea278e3336c5494f0 100644 (file)
@@ -41,7 +41,7 @@ IUSE="${IUSE_VIDEO_CARDS}
        vulkan wayland xa xvmc"
 
 REQUIRED_USE="
-       d3d9?   ( dri3 )
+       d3d9?   ( dri3 || ( video_cards_r300 video_cards_r600 video_cards_radeonsi video_cards_nouveau video_cards_vmware ) )
        gles1?  ( egl )
        gles2?  ( egl )
        vulkan? ( dri3
@@ -250,16 +250,6 @@ llvm_check_deps() {
 }
 
 pkg_pretend() {
-       if use d3d9; then
-               if ! use video_cards_r300 &&
-                  ! use video_cards_r600 &&
-                  ! use video_cards_radeonsi &&
-                  ! use video_cards_nouveau &&
-                  ! use video_cards_vmware; then
-                       ewarn "Ignoring USE=d3d9       since VIDEO_CARDS does not contain r300, r600, radeonsi, nouveau, or vmware"
-               fi
-       fi
-
        if use opencl; then
                if ! use video_cards_r600 &&
                   ! use video_cards_radeonsi; then
@@ -300,7 +290,6 @@ pkg_pretend() {
        fi
 
        if ! use gallium; then
-               use d3d9       && ewarn "Ignoring USE=d3d9       since USE does not contain gallium"
                use lm_sensors && ewarn "Ignoring USE=lm_sensors since USE does not contain gallium"
                use llvm       && ewarn "Ignoring USE=llvm       since USE does not contain gallium"
                use opencl     && ewarn "Ignoring USE=opencl     since USE does not contain gallium"
index 23f29b41b35056d69287eb2225729790db22f36d..46f8ece8fa12b564967b839cffa524a35b4ac41c 100644 (file)
@@ -41,7 +41,7 @@ IUSE="${IUSE_VIDEO_CARDS}
        vulkan wayland xa xvmc"
 
 REQUIRED_USE="
-       d3d9?   ( dri3 )
+       d3d9?   ( dri3 || ( video_cards_r300 video_cards_r600 video_cards_radeonsi video_cards_nouveau video_cards_vmware ) )
        gles1?  ( egl )
        gles2?  ( egl )
        vulkan? ( dri3
@@ -245,16 +245,6 @@ llvm_check_deps() {
 }
 
 pkg_pretend() {
-       if use d3d9; then
-               if ! use video_cards_r300 &&
-                  ! use video_cards_r600 &&
-                  ! use video_cards_radeonsi &&
-                  ! use video_cards_nouveau &&
-                  ! use video_cards_vmware; then
-                       ewarn "Ignoring USE=d3d9       since VIDEO_CARDS does not contain r300, r600, radeonsi, nouveau, or vmware"
-               fi
-       fi
-
        if use opencl; then
                if ! use video_cards_r600 &&
                   ! use video_cards_radeonsi; then
@@ -295,7 +285,6 @@ pkg_pretend() {
        fi
 
        if ! use gallium; then
-               use d3d9       && ewarn "Ignoring USE=d3d9       since USE does not contain gallium"
                use lm_sensors && ewarn "Ignoring USE=lm_sensors since USE does not contain gallium"
                use llvm       && ewarn "Ignoring USE=llvm       since USE does not contain gallium"
                use opencl     && ewarn "Ignoring USE=opencl     since USE does not contain gallium"