net-wireless/iwd: add conditional ell dep
authorBen Kohler <bkohler@gentoo.org>
Fri, 1 Nov 2019 16:17:44 +0000 (11:17 -0500)
committerBen Kohler <bkohler@gentoo.org>
Fri, 1 Nov 2019 16:22:56 +0000 (11:22 -0500)
This will help unify live & release ebuilds a bit more.  Live ebuilds
using internal ell will leave this var unset, but release ebuilds will
set it to the required ell release.

Package-Manager: Portage-2.3.78, Repoman-2.3.17
Signed-off-by: Ben Kohler <bkohler@gentoo.org>
net-wireless/iwd/iwd-9999.ebuild

index 73b6abfd6a456c96c955e09b4ae02ec239f9e63d..3a599ccce340c4c084fffc4c922ae7113b4cc34d 100644 (file)
@@ -4,6 +4,9 @@
 EAPI=6
 inherit flag-o-matic linux-info systemd
 
+#Set this variable to the required external ell version
+ELL_REQ=""
+
 if [[ ${PV} == *9999* ]]; then
        inherit autotools git-r3
        IWD_EGIT_REPO_URI="https://git.kernel.org/pub/scm/network/wireless/iwd.git"
@@ -20,10 +23,11 @@ LICENSE="GPL-2"
 SLOT="0"
 IUSE="+client +crda +monitor ofono wired cpu_flags_x86_aes cpu_flags_x86_ssse3"
 
-COMMON_DEPEND="~dev-libs/ell-9999
-       sys-apps/dbus
+COMMON_DEPEND="sys-apps/dbus
        client? ( sys-libs/readline:0= )"
 
+[[ -z "${ELL_REQ}" ]] || COMMON_DEPEND+="~dev-libs/ell-${ELL_REQ}"
+
 RDEPEND="${COMMON_DEPEND}
        net-wireless/wireless-regdb
        crda? ( net-wireless/crda )"