dev-python/clint: Drop old
authorPacho Ramos <pacho@gentoo.org>
Sat, 10 Mar 2018 14:28:40 +0000 (15:28 +0100)
committerPacho Ramos <pacho@gentoo.org>
Sat, 10 Mar 2018 14:52:15 +0000 (15:52 +0100)
Package-Manager: Portage-2.3.24, Repoman-2.3.6

dev-python/clint/Manifest
dev-python/clint/clint-0.3.1-r1.ebuild [deleted file]
dev-python/clint/clint-0.4.1.ebuild [deleted file]
dev-python/clint/files/clint-setup.patch [deleted file]

index e13aa87033aa48d2b138b712d539b0b74aa8f7af..e1227d68777e5f3180a49711e1556827261633a1 100644 (file)
@@ -1,3 +1 @@
-DIST clint-0.3.1.tar.gz 147154 BLAKE2B c9d4b36a2fc8ae8dd600ad8b0c7e6dead95172cef12d81eaa3bfcab459e20e780c25a3403a0252185680461d735d51247e985c048723d042cc3462d87157679f SHA512 c7a1ccca82d1530e9501f2f854a90f4840cdb4bc2536c8eca30832f156c0898d02d9b839be6b9bf0425b1fa0f94940ef223c55cfd50c183c89b3822ca90b4aba
-DIST clint-0.4.1.tar.gz 80383 BLAKE2B 957440484aff994814d6cb972ad403501f9164d9e02b663adcd20bd4c32a2dc05434ab4c1e0400d4d0d08e617393380c1b5a1775c3a73bdc81212e95ef90d080 SHA512 8ee4fb8d7e5416c0c1c6c23abddb255521a7d682cb855a9fe2446137e83f739a1c44c135a05803632b896fa39400c33f44e5a78442af21bebd3cf66d28fbc9fc
 DIST clint-0.5.1.tar.gz 81140 BLAKE2B 5b42e7d46321f0416d3ffb51edf66c53476d3e4a211e971f36cab54a412f6b0f0ec26486c2b95871956ab09e7e4adf68e8329dd7e9e3c7ed1adb3f8a0dd2a728 SHA512 3ad8bfc587acb1322c7d7c3e73756a07c98f3b4215a3d4dc409b5a2067bc70dce2dd98d19250b8122b319b7bcf5e2859251de2829780345de06f93b35447c4e8
diff --git a/dev-python/clint/clint-0.3.1-r1.ebuild b/dev-python/clint/clint-0.3.1-r1.ebuild
deleted file mode 100644 (file)
index 3293dc7..0000000
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-PYTHON_COMPAT=( python2_7 python3_4 )
-
-inherit distutils-r1 vcs-snapshot
-
-DESCRIPTION="Python Command-line Application Tools"
-HOMEPAGE="https://github.com/kennethreitz/clint"
-SRC_URI="https://github.com/kennethreitz/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="ISC"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="doc examples test"
-
-DEPEND="
-       doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
-       test? ( dev-python/pytest[${PYTHON_USEDEP}] )
-"
-RDEPEND=""
-
-# Prevent install of files to wrong location
-PATCHES=( "${FILESDIR}"/${PN}-setup.patch )
-
-python_compile_all() {
-       use doc && emake -C docs html
-}
-
-python_test() {
-       py.test || die "Tests failed under ${EPYTHON}"
-}
-
-python_install_all() {
-       use doc && local HTML_DOCS=( docs/_build/html/. )
-       use examples && local EXAMPLES=( examples/. )
-
-       distutils-r1_python_install_all
-}
diff --git a/dev-python/clint/clint-0.4.1.ebuild b/dev-python/clint/clint-0.4.1.ebuild
deleted file mode 100644 (file)
index f62ce78..0000000
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-PYTHON_COMPAT=( python2_7 python3_4 )
-
-inherit distutils-r1 vcs-snapshot
-
-DESCRIPTION="Python Command-line Application Tools"
-HOMEPAGE="https://github.com/kennethreitz/clint"
-SRC_URI="https://github.com/kennethreitz/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="ISC"
-SLOT="0"
-KEYWORDS="~x86 ~amd64"
-IUSE="doc examples test"
-
-DEPEND="
-       doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
-       test? ( dev-python/pytest[${PYTHON_USEDEP}] )
-"
-RDEPEND="dev-python/args[${PYTHON_USEDEP}]"
-
-python_compile_all() {
-       use doc && emake -C docs html
-}
-
-python_test() {
-       py.test || die "Tests failed under ${EPYTHON}"
-}
-
-python_install_all() {
-       use doc && local HTML_DOCS=( docs/_build/html/. )
-       use examples && local EXAMPLES=( examples/. )
-
-       distutils-r1_python_install_all
-}
diff --git a/dev-python/clint/files/clint-setup.patch b/dev-python/clint/files/clint-setup.patch
deleted file mode 100644 (file)
index 960dc99..0000000
+++ /dev/null
@@ -1,15 +0,0 @@
-setup.py installs data files to /usr/ !!!??!!
-diff -ur clint-0.3.1.orig/setup.py clint-0.3.1/setup.py
---- setup.py   2012-01-16 22:25:54.000000000 +0800
-+++ setup.py   2014-10-11 12:20:29.174133572 +0800
-@@ -29,10 +29,6 @@
-     author='Kenneth Reitz',
-     author_email='me@kennethreitz.com',
-     url='https://github.com/kennethreitz/clint',
--    data_files=[
--        'README.rst',
--        'HISTORY.rst',
--    ],
-     packages= [
-         'clint',
-         'clint.textui',