arm/s390/sh stable #163692
authorMike Frysinger <vapier@gentoo.org>
Sun, 11 Feb 2007 10:45:04 +0000 (10:45 +0000)
committerMike Frysinger <vapier@gentoo.org>
Sun, 11 Feb 2007 10:45:04 +0000 (10:45 +0000)
Package-Manager: portage-2.1.2-r9

net-dns/bind/bind-9.3.3.ebuild
net-dns/bind/bind-9.3.4.ebuild
net-dns/idnkit/idnkit-1.0.ebuild

index 5e024ef4662aebfa3b21cde95a4a8f7072cafbc5..fb2eb6a480d2e3c710de56d5cbff612882373777 100644 (file)
@@ -1,6 +1,6 @@
 # Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/bind/bind-9.3.3.ebuild,v 1.9 2007/02/07 22:48:23 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/bind/bind-9.3.3.ebuild,v 1.10 2007/02/11 10:45:04 vapier Exp $
 
 inherit eutils libtool autotools
 
@@ -14,7 +14,7 @@ SRC_URI="ftp://ftp.isc.org/isc/bind9/${PV}/${P}.tar.gz
 
 LICENSE="as-is"
 SLOT="0"
-KEYWORDS="~alpha amd64 ~arm hppa ~ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~x86-fbsd"
+KEYWORDS="~alpha amd64 arm hppa ~ia64 ~mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd"
 IUSE="ssl ipv6 doc dlz postgres berkdb mysql odbc ldap selinux idn threads resolvconf"
 
 DEPEND="!net-dns/idnkit
index 153639883822a1ec3cafe1a42f8be588b5d0b38a..e0bbe7e6a6e178bf9c1b10b631feec91bffd2eb4 100644 (file)
@@ -1,6 +1,6 @@
 # Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/bind/bind-9.3.4.ebuild,v 1.7 2007/02/10 20:15:54 yoswink Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/bind/bind-9.3.4.ebuild,v 1.8 2007/02/11 10:45:04 vapier Exp $
 
 inherit eutils libtool autotools
 
@@ -14,7 +14,7 @@ SRC_URI="ftp://ftp.isc.org/isc/bind9/${PV}/${P}.tar.gz
 
 LICENSE="as-is"
 SLOT="0"
-KEYWORDS="alpha ~amd64 hppa ppc ~ppc64 sparc x86"
+KEYWORDS="alpha ~amd64 arm hppa ppc ~ppc64 s390 sh sparc x86"
 IUSE="ssl ipv6 doc dlz postgres berkdb mysql odbc ldap selinux idn threads resolvconf"
 
 DEPEND="ssl? ( >=dev-libs/openssl-0.9.6g )
@@ -23,7 +23,6 @@ DEPEND="ssl? ( >=dev-libs/openssl-0.9.6g )
        ldap? ( net-nds/openldap )
        idn? ( net-dns/idnkit )
        resolvconf? ( net-dns/resolvconf-gentoo )"
-
 RDEPEND="${DEPEND}
        selinux? ( sec-policy/selinux-bind )"
 
index 1be049b9a1aea77cae0bb9d8b4d74b6b5e2bebd1..23b31a27e3c5722bb83c9809617950e8f77ce519 100644 (file)
@@ -1,31 +1,28 @@
 # Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/idnkit/idnkit-1.0.ebuild,v 1.19 2007/02/10 20:00:29 yoswink Exp $
-
-S="${WORKDIR}/${P}-src"
+# $Header: /var/cvsroot/gentoo-x86/net-dns/idnkit/idnkit-1.0.ebuild,v 1.20 2007/02/11 10:44:53 vapier Exp $
 
 DESCRIPTION="Toolkit for Internationalized Domain Names (IDN)"
 HOMEPAGE="http://www.nic.ad.jp/ja/idn/idnkit/download/"
 SRC_URI="http://www.nic.ad.jp/ja/idn/idnkit/download/sources/${P}-src.tar.gz"
 
-SLOT="0"
 LICENSE="JNIC"
-KEYWORDS="alpha ~amd64 hppa ppc ~ppc64 sparc x86"
+SLOT="0"
+KEYWORDS="alpha ~amd64 arm hppa ppc ~ppc64 s390 sh sparc x86"
 IUSE=""
 
 DEPEND="sys-libs/glibc"
 # non gnu systems need libiconv
 
-src_unpack()
-{
-       unpack ${A} ; cd ${S}
+S=${WORKDIR}/${P}-src
+
+src_unpack() {
+       unpack ${A}
+       cd "${S}"
        sed -i -e "s:head -1:head -n 1:g" *
 }
 
-src_install()
-{
-       make DESTDIR="${D}" install
-       dodoc Changelog DISTFILES INSTALL INSTALL.ja LICENSE.txt NEWS \
-               README README.ja
-
+src_install() {
+       emake DESTDIR="${D}" install || die
+       dodoc Changelog DISTFILES INSTALL INSTALL.ja NEWS README README.ja
 }