dev-python/sphinx_rtd_theme: Revbump to drop py2
authorMichał Górny <mgorny@gentoo.org>
Thu, 5 Mar 2020 18:02:53 +0000 (19:02 +0100)
committerMichał Górny <mgorny@gentoo.org>
Thu, 5 Mar 2020 18:02:53 +0000 (19:02 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/sphinx_rtd_theme/sphinx_rtd_theme-0.4.3-r1.ebuild [new file with mode: 0644]

diff --git a/dev-python/sphinx_rtd_theme/sphinx_rtd_theme-0.4.3-r1.ebuild b/dev-python/sphinx_rtd_theme/sphinx_rtd_theme-0.4.3-r1.ebuild
new file mode 100644 (file)
index 0000000..9b07580
--- /dev/null
@@ -0,0 +1,27 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{6,7,8} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="ReadTheDocs.org theme for Sphinx"
+HOMEPAGE="https://github.com/readthedocs/sphinx_rtd_theme"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+PDEPEND="dev-python/sphinx[${PYTHON_USEDEP}]"
+BDEPEND="
+       test? (
+               ${PDEPEND}
+               dev-python/readthedocs-sphinx-ext[${PYTHON_USEDEP}]
+       )"
+
+distutils_enable_tests pytest