app-portage/tatt: version bump 0.4
authorMichael Palimaka <kensington@gentoo.org>
Sat, 18 Mar 2017 05:23:31 +0000 (16:23 +1100)
committerMichael Palimaka <kensington@gentoo.org>
Sat, 18 Mar 2017 05:26:39 +0000 (16:26 +1100)
Package-Manager: Portage-2.3.5, Repoman-2.3.2

app-portage/tatt/Manifest
app-portage/tatt/tatt-0.4.ebuild [new file with mode: 0644]

index 0c1a9466e78532ef09cdfa0a0a85a400bd3c5ab0..6f7d9cf32d700c77c02471c3799eb6ce10bfb37d 100644 (file)
@@ -1 +1,2 @@
 DIST tatt-0.3.tar.gz 22527 SHA256 bad1f0f33889aaa5887bab8c80bcbdaa620c379de5ff381ab983ae23d24ac9ed SHA512 822ec8904e452afd2373ca7ff01a05b8020b261acfc02864523a22e91d83dea51a1d2a8c79ec75db38e6de00cb3c06b3799dee261f376ec91d261a9f468aaa19 WHIRLPOOL f9be83b45c3d79e004600fa3e1ecd2d1ab6e6720035f13ab5f0b4a46555c280663e6371fb9ed88ab0de6bbfb4a853a0f07963dbc25f668a3cd8482c369343b90
+DIST tatt-0.4.tar.gz 23397 SHA256 53ed63685187acc55241698dac26a7cadbdf846dfc72709a9d67db65572dc2ef SHA512 57df8cdda9b6711da36e3635182fcfb64a376d7c3a76a29ea0252fc17597defe921d90bf9989f4fc199ab9848fae6fc4f53623140825f79368e90723a5562dd6 WHIRLPOOL a152e6cdee833d892eb0ff1b6c24d107b99ac4b7c92510d230fdbb6e1375825c1294a7008e1e09c496115f6116f3de48a4500dcc3a257998c8ee5bb0a29c08b0
diff --git a/app-portage/tatt/tatt-0.4.ebuild b/app-portage/tatt/tatt-0.4.ebuild
new file mode 100644 (file)
index 0000000..f9f9609
--- /dev/null
@@ -0,0 +1,38 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_4 )
+
+inherit distutils-r1
+
+DESCRIPTION="arch testing tool"
+HOMEPAGE="https://github.com/kensington/tatt"
+SRC_URI="https://github.com/kensington/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="+templates"
+
+RDEPEND="
+       app-portage/eix
+       app-portage/gentoolkit
+       dev-python/configobj[${PYTHON_USEDEP}]
+       dev-python/requests[${PYTHON_USEDEP}]
+       www-client/pybugz
+"
+DEPEND="${RDEPEND}
+       dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+python_install_all() {
+       distutils-r1_python_install_all
+       if use templates; then
+               insinto "/usr/share/${PN}"
+               doins -r templates
+       fi
+       doman tatt.1
+       doman tatt.5
+}