dev-util/bitcoin-tx-0.17.1: Fix build without libevent
authorLuke Dashjr <luke-jr+git@utopios.org>
Sat, 12 Jan 2019 13:46:11 +0000 (13:46 +0000)
committerCraig Andrews <candrews@gentoo.org>
Sun, 13 Jan 2019 03:17:18 +0000 (22:17 -0500)
Fixes: https://bugs.gentoo.org/675256
Signed-off-by: Luke Dashjr <luke-jr+git@utopios.org>
Signed-off-by: Craig Andrews <candrews@gentoo.org>
dev-util/bitcoin-tx/bitcoin-tx-0.17.1.ebuild
dev-util/bitcoin-tx/files/0.17.1-no-libevent.patch [new file with mode: 0644]

index a431bbafab7320ae0e2b7a6e0ee232037cd218a6..4346aa0259165bbc973a8bf807afa1f15febb449 100644 (file)
@@ -63,6 +63,8 @@ src_prepare() {
        mkdir -p src/obj || die
        echo "#define BUILD_SUFFIX gentoo${PVR#${PV}}" >src/obj/build.h || die
 
+       eapply "${FILESDIR}/${PV}-no-libevent.patch"
+
        eautoreconf
        rm -r src/leveldb src/secp256k1 || die
 }
diff --git a/dev-util/bitcoin-tx/files/0.17.1-no-libevent.patch b/dev-util/bitcoin-tx/files/0.17.1-no-libevent.patch
new file mode 100644 (file)
index 0000000..b0e4a95
--- /dev/null
@@ -0,0 +1,20 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -1101,7 +1101,7 @@ if test x$use_pkgconfig = xyes; then
+       if test x$use_qr != xno; then
+         BITCOIN_QT_CHECK([PKG_CHECK_MODULES([QR], [libqrencode], [have_qrencode=yes], [have_qrencode=no])])
+       fi
+-      if test x$build_bitcoin_cli$build_bitcoin_tx$build_bitcoind$bitcoin_enable_qt$use_tests != xnonononono; then
++      if test x$build_bitcoin_cli$build_bitcoind$bitcoin_enable_qt$use_tests != xnononono; then
+         PKG_CHECK_MODULES([EVENT], [libevent],, [AC_MSG_ERROR(libevent not found.)])
+         if test x$TARGET_OS != xwindows; then
+           PKG_CHECK_MODULES([EVENT_PTHREADS], [libevent_pthreads],, [AC_MSG_ERROR(libevent_pthreads not found.)])
+@@ -1126,7 +1126,7 @@ else
+   AC_CHECK_HEADER([openssl/ssl.h],, AC_MSG_ERROR(libssl headers missing),)
+   AC_CHECK_LIB([ssl],         [main],SSL_LIBS=-lssl, AC_MSG_ERROR(libssl missing))
+-  if test x$build_bitcoin_cli$build_bitcoin_tx$build_bitcoind$bitcoin_enable_qt$use_tests != xnonononono; then
++  if test x$build_bitcoin_cli$build_bitcoind$bitcoin_enable_qt$use_tests != xnononono; then
+     AC_CHECK_HEADER([event2/event.h],, AC_MSG_ERROR(libevent headers missing),)
+     AC_CHECK_LIB([event],[main],EVENT_LIBS=-levent,AC_MSG_ERROR(libevent missing))
+     if test x$TARGET_OS != xwindows; then