dev-php/PEAR-Math_BigInteger: new revision sans PEAR dependency.
authorMichael Orlitzky <mjo@gentoo.org>
Sat, 8 Apr 2017 18:44:50 +0000 (14:44 -0400)
committerMichael Orlitzky <mjo@gentoo.org>
Sat, 8 Apr 2017 18:45:13 +0000 (14:45 -0400)
Gentoo-Bug: 614892

Package-Manager: Portage-2.3.3, Repoman-2.3.1

dev-php/PEAR-Math_BigInteger/PEAR-Math_BigInteger-1.0.3-r1.ebuild [new file with mode: 0644]
dev-php/PEAR-Math_BigInteger/PEAR-Math_BigInteger-1.0.3.ebuild [deleted file]
dev-php/PEAR-Math_BigInteger/metadata.xml

diff --git a/dev-php/PEAR-Math_BigInteger/PEAR-Math_BigInteger-1.0.3-r1.ebuild b/dev-php/PEAR-Math_BigInteger/PEAR-Math_BigInteger-1.0.3-r1.ebuild
new file mode 100644 (file)
index 0000000..5aad882
--- /dev/null
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MY_PN="${PN/PEAR-/}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Pure-PHP arbitrary precision integer arithmetic library"
+HOMEPAGE="http://pear.php.net/package/${MY_PN}
+       http://phpseclib.sourceforge.net/documentation/math.html"
+SRC_URI="http://download.pear.php.net/package/${MY_P}.tgz"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+DEPEND=""
+RDEPEND="dev-lang/php:*"
+
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+       insinto /usr/share/php
+       doins -r Math
+
+       dodoc demo/{benchmark,demo}.php
+}
diff --git a/dev-php/PEAR-Math_BigInteger/PEAR-Math_BigInteger-1.0.3.ebuild b/dev-php/PEAR-Math_BigInteger/PEAR-Math_BigInteger-1.0.3.ebuild
deleted file mode 100644 (file)
index 10f66b7..0000000
+++ /dev/null
@@ -1,15 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit php-pear-r1
-
-DESCRIPTION="Pure-PHP arbitrary precision integer arithmetic library"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
-IUSE=""
-
-RDEPEND=">=dev-lang/php-5.3.0"
index aca42932b83363b2b3b1f1ff5c7ce1ccccf24838..04d9b1663bd1baac06e08cb4ba158465295804eb 100644 (file)
@@ -1,8 +1,8 @@
 <?xml version="1.0" encoding="UTF-8"?>
 <!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
 <pkgmetadata>
-<maintainer type="project">
-       <email>php-bugs@gentoo.org</email>
-       <name>PHP</name>
-</maintainer>
+  <maintainer type="project">
+    <email>php-bugs@gentoo.org</email>
+    <name>PHP</name>
+  </maintainer>
 </pkgmetadata>