dev-python/nagiosplugin: Initial import. Fixes bug 568876.
authorPatrice Clement <monsieurp@gentoo.org>
Mon, 21 Dec 2015 23:41:55 +0000 (23:41 +0000)
committerPatrice Clement <monsieurp@gentoo.org>
Mon, 21 Dec 2015 23:43:00 +0000 (23:43 +0000)
Package-Manager: portage-2.2.20.1
Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
dev-python/nagiosplugin/Manifest [new file with mode: 0644]
dev-python/nagiosplugin/metadata.xml [new file with mode: 0644]
dev-python/nagiosplugin/nagiosplugin-1.2.3.ebuild [new file with mode: 0644]

diff --git a/dev-python/nagiosplugin/Manifest b/dev-python/nagiosplugin/Manifest
new file mode 100644 (file)
index 0000000..b018c5d
--- /dev/null
@@ -0,0 +1 @@
+DIST nagiosplugin-1.2.3.tar.gz 37570 SHA256 9a1729d6479b71b1c7184e88a6214b00133953921df1be2d14ccb35a94a3c8dd SHA512 3f3045db181acc144cb41871f2f67090a7b096d600c9cda7e4f9b86648d47319dca7c42b74670ba307c0bc60955eb33aefcde9c895e544bbb4c7ca1f80e8919d WHIRLPOOL 2482a04ba7280973e9c4f8faedc4c54ca193bd1ff3d37c608dc4018dc2e39dd719e43edac7393c9102436ff8f5dacbeaa3df32c9523924aa6474ca20cdc83445
diff --git a/dev-python/nagiosplugin/metadata.xml b/dev-python/nagiosplugin/metadata.xml
new file mode 100644 (file)
index 0000000..f5bafd5
--- /dev/null
@@ -0,0 +1,13 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+  <herd>proxy-maintainers</herd>
+  <maintainer>
+         <email>sautier.louis@gmail.com</email>
+         <name>Louis Sautier</name>
+  </maintainer>
+  <upstream>
+         <remote-id type="pypi">nagiosplugin</remote-id>
+         <remote-id type="bitbucket">flyingcircus/nagiosplugin</remote-id>
+  </upstream>
+</pkgmetadata>
diff --git a/dev-python/nagiosplugin/nagiosplugin-1.2.3.ebuild b/dev-python/nagiosplugin/nagiosplugin-1.2.3.ebuild
new file mode 100644 (file)
index 0000000..9359a40
--- /dev/null
@@ -0,0 +1,25 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4,3_5} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="A class library for writing nagios-compatible plugins"
+HOMEPAGE="https://bitbucket.org/flyingcircus/nagiosplugin/ https://pypi.python.org/pypi/nagiosplugin/"
+if [[ ${PV} == "9999" ]] ; then
+       inherit mercurial
+       EHG_REPO_URI="https://bitbucket.org/flyingcircus/nagiosplugin/"
+else
+       SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+       KEYWORDS="~amd64"
+fi
+
+LICENSE="ZPL"
+SLOT="0"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"