net-mail/qmhandle: bump EAPI and stuff
authorAaron Bauman <bman@gentoo.org>
Sun, 10 Nov 2019 03:37:37 +0000 (22:37 -0500)
committerAaron Bauman <bman@gentoo.org>
Sun, 10 Nov 2019 03:43:58 +0000 (22:43 -0500)
Signed-off-by: Aaron Bauman <bman@gentoo.org>
net-mail/qmhandle/qmhandle-1.3.2.ebuild

index ca310ec47ede2096ee2de28fbc6c816429103e33..b335ed852a207e2c9e91149fa4b3a58972d4dd7a 100644 (file)
@@ -1,9 +1,7 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=0
-
-inherit eutils
+EAPI=7
 
 DESCRIPTION="Qmail message queue tool"
 HOMEPAGE="http://qmhandle.sourceforge.net/"
@@ -20,16 +18,15 @@ RDEPEND="virtual/qmail
 "
 DEPEND=""
 
-src_unpack() {
-       unpack ${A}
-       cd "${S}"
+src_prepare() {
        sed \
                -e 's|/usr/local/bin/svc|/usr/bin/svc|g' \
                -e 's|/service/qmail-deliver|/var/qmail/supervise/qmail-send|g' \
-               -i qmHandle
+               -i qmHandle || die "Fixing qmHandle failed"
+       eapply_user
 }
 
 src_install() {
        dodoc README HISTORY
-       dobin qmHandle || die "dobin failed"
+       dobin qmHandle
 }