dev-python/fields: Remove old
authorMichał Górny <mgorny@gentoo.org>
Wed, 25 Mar 2020 13:54:18 +0000 (14:54 +0100)
committerMichał Górny <mgorny@gentoo.org>
Wed, 25 Mar 2020 13:59:29 +0000 (14:59 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/fields/fields-5.0.0-r1.ebuild [deleted file]
dev-python/fields/fields-5.0.0.ebuild [deleted file]

diff --git a/dev-python/fields/fields-5.0.0-r1.ebuild b/dev-python/fields/fields-5.0.0-r1.ebuild
deleted file mode 100644 (file)
index 32f5b73..0000000
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python2_7 python3_{6,7} pypy3 )
-inherit distutils-r1
-
-DESCRIPTION="Container class boilerplate killer"
-HOMEPAGE="https://github.com/ionelmc/python-fields"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD-2"
-SLOT="0"
-KEYWORDS="~alpha amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
-IUSE="test"
-
-DEPEND="test? ( dev-python/pytest[${PYTHON_USEDEP}]
-       dev-python/attrs[${PYTHON_USEDEP}]
-       dev-python/characteristic[${PYTHON_USEDEP}] )"
-
-RESTRICT="!test? ( test )"
-
-python_prepare_all() {
-       sed -i -e "/--benchmark-disable/d" setup.cfg || die
-       rm -rf tests/test_perf.py || die
-       distutils-r1_python_prepare_all
-}
-
-python_test() {
-       py.test -vv || die
-}
diff --git a/dev-python/fields/fields-5.0.0.ebuild b/dev-python/fields/fields-5.0.0.ebuild
deleted file mode 100644 (file)
index 2ed7371..0000000
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_6 pypy3 )
-inherit distutils-r1
-
-DESCRIPTION="Container class boilerplate killer"
-HOMEPAGE="https://github.com/ionelmc/python-fields"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD-2"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
-IUSE="test"
-
-DEPEND="test? ( dev-python/pytest[${PYTHON_USEDEP}]
-       dev-python/attrs[${PYTHON_USEDEP}]
-       dev-python/characteristic[${PYTHON_USEDEP}] )"
-
-RESTRICT="!test? ( test )"
-
-python_prepare_all() {
-       sed -i -e "/--benchmark-disable/d" setup.cfg || die
-       rm -rf tests/test_perf.py || die
-       distutils-r1_python_prepare_all
-}
-
-python_test() {
-       py.test -vv || die
-}