dev-python/pygame_sdl2: initial import of version 6.99.5
authorJulian Ospald <hasufell@gentoo.org>
Sun, 9 Aug 2015 14:35:05 +0000 (16:35 +0200)
committerJulian Ospald <hasufell@gentoo.org>
Sun, 9 Aug 2015 14:40:53 +0000 (16:40 +0200)
Preparation for games-engines/renpy-6.99.5 bump.

dev-python/pygame_sdl2/Manifest [new file with mode: 0644]
dev-python/pygame_sdl2/metadata.xml [new file with mode: 0644]
dev-python/pygame_sdl2/pygame_sdl2-6.99.5.ebuild [new file with mode: 0644]

diff --git a/dev-python/pygame_sdl2/Manifest b/dev-python/pygame_sdl2/Manifest
new file mode 100644 (file)
index 0000000..09704a2
--- /dev/null
@@ -0,0 +1 @@
+DIST pygame_sdl2-for-renpy-6.99.5.tar.bz2 131886 SHA256 3cfe05da83fa115c7fa10ae7aac88979ba9b5ba73986205b89b3bb25c4687230 SHA512 9aa66af47f4ba4bd0ad7d9fa96cbca08b5997e028ca4ba9a4b7f5880d0ce0241002570e687b65fa0176584bee59294760835bfd4addec086fd1cc6d1c67a887c WHIRLPOOL 7f5a132285b821650551790b169a66f7d69c29a246728efe48b33a4c615cad63e6c45c545b292684024c6dac8a65a3e7d2711b4369f1916d307dfef8e993c4c5
diff --git a/dev-python/pygame_sdl2/metadata.xml b/dev-python/pygame_sdl2/metadata.xml
new file mode 100644 (file)
index 0000000..a309a9b
--- /dev/null
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+       <maintainer>
+               <email>hasufell@gentoo.org</email>
+               <name>Julian Ospald</name>
+       </maintainer>
+</pkgmetadata>
diff --git a/dev-python/pygame_sdl2/pygame_sdl2-6.99.5.ebuild b/dev-python/pygame_sdl2/pygame_sdl2-6.99.5.ebuild
new file mode 100644 (file)
index 0000000..c9e788c
--- /dev/null
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_3 python3_4 )
+inherit distutils-r1
+
+DESCRIPTION="Reimplementation of portions of the pygame API using SDL2"
+HOMEPAGE="https://github.com/renpy/pygame_sdl2"
+SRC_URI="http://www.renpy.org/dl/${PV}/pygame_sdl2-for-renpy-${PV}.tar.bz2"
+
+LICENSE="LGPL-2.1 ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-python/numpy[${PYTHON_USEDEP}]
+       media-libs/libpng:0
+       media-libs/libsdl2[video]
+       media-libs/sdl2-image[png,jpeg]
+       media-libs/sdl2-mixer
+       media-libs/sdl2-ttf
+       virtual/jpeg:62
+"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/pygame-sdl2-for-renpy-${PV}