dev-util/itstool: Switch to PYTHON_MULTI_USEDEP API
authorMichał Górny <mgorny@gentoo.org>
Fri, 7 Feb 2020 13:12:17 +0000 (14:12 +0100)
committerMichał Górny <mgorny@gentoo.org>
Sun, 9 Feb 2020 16:21:40 +0000 (17:21 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-util/itstool/itstool-2.0.2.ebuild
dev-util/itstool/itstool-2.0.6-r1.ebuild [moved from dev-util/itstool/itstool-2.0.6.ebuild with 91% similarity]

index c970a0e502df099a15218594ccb9e06c10373875..2606e551b64771bc21413735e0b524a07c6db992 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=5
@@ -21,7 +21,9 @@ IUSE=""
 REQUIRED_USE="${PYTHON_REQUIRED_USE}"
 
 RDEPEND="${PYTHON_DEPS}
-       dev-libs/libxml2[python,${PYTHON_USEDEP}]"
+       $(python_gen_cond_dep '
+               dev-libs/libxml2[python,${PYTHON_MULTI_USEDEP}]
+       ')"
 DEPEND="${RDEPEND}"
 
 pkg_setup() {
similarity index 91%
rename from dev-util/itstool/itstool-2.0.6.ebuild
rename to dev-util/itstool/itstool-2.0.6-r1.ebuild
index 444c8f20eec7b95d5ee4f3acd71d4c321f50e04d..d277093282fd7b0f74dcac0b870dd8a9ca9e6157 100644 (file)
@@ -21,7 +21,9 @@ IUSE=""
 REQUIRED_USE="${PYTHON_REQUIRED_USE}"
 
 RDEPEND="${PYTHON_DEPS}
-       dev-libs/libxml2[python,${PYTHON_USEDEP}]"
+       $(python_gen_cond_dep '
+               dev-libs/libxml2[python,${PYTHON_MULTI_USEDEP}]
+       ')"
 DEPEND="${RDEPEND}"
 BDEPEND=""