dev-python/pycountry: version bump to 17.9.23
authorTim Harder <radhermit@gentoo.org>
Thu, 19 Oct 2017 08:09:44 +0000 (04:09 -0400)
committerTim Harder <radhermit@gentoo.org>
Thu, 19 Oct 2017 08:19:41 +0000 (04:19 -0400)
dev-python/pycountry/Manifest
dev-python/pycountry/pycountry-17.9.23.ebuild [new file with mode: 0644]

index 3567424fc084d7c4fff2abb5c89aa1f9854c00a5..ef57c2a3d07387a837c15c634ff2236112c6e706 100644 (file)
@@ -1,2 +1,3 @@
 DIST pycountry-16.11.8.tar.gz 9042735 SHA256 c9a0536699dfb46fb43ae1449999a921a79361030773bc3d35e00abfecb437c2 SHA512 eb0a91f1efae6aeace0b49cd44b0770efa0b57add208c4247e7f58a3c46774f9f8007c51ee88a0e108c90ced3ad69204b4322c9c23f51df0b2202aa98c314a37 WHIRLPOOL 7eb1bbe51ba14c3b4d1c4e210cf9698fef1b99d0b96c5800985d73431ada5604996f7412e3c0c7440dccaa052fe284f0babd660bc82b28508ed6abbaa7b78f16
 DIST pycountry-17.5.14.tar.gz 9203433 SHA256 d31321e59a134aac326ac07d4b2595d63f7e7f755bcb503bdecca2bd1b54ff2f SHA512 bf5a13ce128f9512287f09c3edb565a3493bf490e420a01c8a45bbb96cfb2482674e8c81cf4db909a92db647f4ba71d03f4aca51995f6c64e4eb59f5c617bcea WHIRLPOOL 2f6b3125f0c1cfa3a7b20833aa74eff652a68a1834f4334fef01f475a340f36a2217c3e564087e77530032c21e46bd4970ca4c49ff3f5f2bf5b4a6b4dadc3c5f
+DIST pycountry-17.9.23.tar.gz 9208478 SHA256 173c5e3a8884c5616c6595078cc8f27e65ce59c6d9aa8864bace0c6b1281c57a SHA512 168e2d2693629a39a85a4c6aa7187323693ca73d6af0cc947d3536ae373eca602e7e3add91ba114966db4ebf52118ef3d6a3dbf8339734ec68682bab559beeb5 WHIRLPOOL 12660ba0cd00438da8321a80b3085fdd9ffcfd4b212fd3bc5fbf5d55f73a5dd6c27fa51890277f055e519c030b2cf933492f1d40a613ca9cdd72795bbe05061c
diff --git a/dev-python/pycountry/pycountry-17.9.23.ebuild b/dev-python/pycountry/pycountry-17.9.23.ebuild
new file mode 100644 (file)
index 0000000..5ab90f3
--- /dev/null
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Database of countries, subdivisions, languages, currencies and script"
+HOMEPAGE="https://bitbucket.org/flyingcircus/pycountry"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~sparc ~x86"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+       test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+python_test() {
+       # https://bitbucket.org/techtonik/pycountry/issue/8/test_locales-pycountry-015-pypy
+       pushd "${BUILD_DIR}"/lib > /dev/null
+       if [[ "${EPYTHON}" == pypy || "${EPYTHON}" == pypy3 ]]; then
+               sed -e 's:test_locales:_&:' -i pycountry/tests/test_general.py || die
+       fi
+       py.test ${PN}/tests/test_general.py || die
+       popd > /dev/null
+}