dev-python/python_orocos_kdl: Install package.xml in our custom gentoo path from...
authorAlexis Ballier <aballier@gentoo.org>
Tue, 28 Feb 2017 10:43:53 +0000 (11:43 +0100)
committerAlexis Ballier <aballier@gentoo.org>
Tue, 28 Feb 2017 11:26:50 +0000 (12:26 +0100)
Package-Manager: Portage-2.3.3, Repoman-2.3.1

dev-python/python_orocos_kdl/python_orocos_kdl-1.3.1-r1.ebuild
dev-python/python_orocos_kdl/python_orocos_kdl-9999.ebuild

index 227c40d706fd619fffefe2c7c2086dfb4f266e36..c8144ed108eb33702a137ca8099dc11f2233a4cb 100644 (file)
@@ -32,7 +32,6 @@ RDEPEND="
        dev-python/sip[${PYTHON_USEDEP}]
 "
 DEPEND="${RDEPEND}"
-PATCHES=( "${FILESDIR}/gentoo.patch" )
 
 if [ "${PV#9999}" != "${PV}" ] ; then
        S=${WORKDIR}/${P}/python_orocos_kdl
@@ -54,4 +53,8 @@ src_test() {
 
 src_install() {
        python_foreach_impl cmake-utils_src_install
+
+       # Need to have package.xml in our custom gentoo path
+       insinto /usr/share/ros_packages/${PN}
+       doins "${ED}/usr/share/${PN}/package.xml"
 }
index 89a4b94a2885f241264db3b0a3eb5c834f48f9d3..c8144ed108eb33702a137ca8099dc11f2233a4cb 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Id$
 
@@ -32,7 +32,6 @@ RDEPEND="
        dev-python/sip[${PYTHON_USEDEP}]
 "
 DEPEND="${RDEPEND}"
-PATCHES=( "${FILESDIR}/gentoo.patch" )
 
 if [ "${PV#9999}" != "${PV}" ] ; then
        S=${WORKDIR}/${P}/python_orocos_kdl
@@ -54,4 +53,8 @@ src_test() {
 
 src_install() {
        python_foreach_impl cmake-utils_src_install
+
+       # Need to have package.xml in our custom gentoo path
+       insinto /usr/share/ros_packages/${PN}
+       doins "${ED}/usr/share/${PN}/package.xml"
 }