dev-ros/qt_gui_cpp: Bump to 0.3.9.
authorAlexis Ballier <aballier@gentoo.org>
Sat, 4 Aug 2018 18:27:05 +0000 (20:27 +0200)
committerAlexis Ballier <aballier@gentoo.org>
Sat, 4 Aug 2018 18:46:30 +0000 (20:46 +0200)
Package-Manager: Portage-2.3.44, Repoman-2.3.10

dev-ros/qt_gui_cpp/Manifest
dev-ros/qt_gui_cpp/qt_gui_cpp-0.3.9.ebuild [new file with mode: 0644]

index 32e863ede88bfcf39d44042f8dd37ad61e63afdc..d04327f8b2f5239916ffe91af5be6c246a861a08 100644 (file)
@@ -1 +1,2 @@
 DIST qt_gui_core-0.3.8.tar.gz 91248 BLAKE2B 9ed159b8d065e7b2a44dcf9ac496a699675e5ec41d5ed222413894f098e122b092c976c934dc37a99846e0fe80858fb377bf937b3eabc3f0c6df126de7944e88 SHA512 aec926adffc9f1ab84d7d5cccb207d87254496b37e9e2e4c430de191917823424751206647d61821a65dec0aad3241dab22c85f21980fbe1a4bf114bb2c29d70
+DIST qt_gui_core-0.3.9.tar.gz 91495 BLAKE2B c0f2f2b9231a42da68c0032bfb192a47060f4b0915952b77750985be00023f22678480605990a79016b8ed906cacbdb9cd7eafabbb917b06f891f6b7817a999c SHA512 3e7e45001f1749e3ca75c6b33e3e7a131a314a5ec66925b86f2617f6f749f4c2093d33420bbe0f148faa44fb1fb3071241e47180d3c56ed9d1f7a2befb006a95
diff --git a/dev-ros/qt_gui_cpp/qt_gui_cpp-0.3.9.ebuild b/dev-ros/qt_gui_cpp/qt_gui_cpp-0.3.9.ebuild
new file mode 100644 (file)
index 0000000..a52422e
--- /dev/null
@@ -0,0 +1,34 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros-visualization/qt_gui_core"
+KEYWORDS="~amd64"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Foundation for C++-bindings for dev-ros/qt_gui and creates bindings for every generator available"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+       dev-qt/qtcore:5
+       dev-qt/qtwidgets:5
+       >=dev-ros/pluginlib-1.9.23
+               dev-libs/tinyxml2:=
+       >=dev-ros/qt_gui-0.3.0[${PYTHON_USEDEP}]
+       dev-libs/tinyxml
+       >=dev-ros/python_qt_binding-0.3.0[${PYTHON_USEDEP}]
+       dev-libs/boost:=
+       dev-libs/console_bridge:=
+"
+DEPEND="${RDEPEND}
+       virtual/pkgconfig
+"
+PATCHES=(
+       "${FILESDIR}/libdir.patch"
+)