net-libs/gupnp-igd: remove old
authorMart Raudsepp <leio@gentoo.org>
Mon, 14 Jan 2019 19:49:37 +0000 (21:49 +0200)
committerMart Raudsepp <leio@gentoo.org>
Mon, 14 Jan 2019 19:51:23 +0000 (21:51 +0200)
Package-Manager: Portage-2.3.52, Repoman-2.3.12
Signed-off-by: Mart Raudsepp <leio@gentoo.org>
net-libs/gupnp-igd/Manifest
net-libs/gupnp-igd/files/gupnp-igd-0.1.11-disable_static_modules.patch [deleted file]
net-libs/gupnp-igd/gupnp-igd-0.2.4.ebuild [deleted file]

index 119e1afa2ea7dedcdac5b376b361a9e5f4a5bd4f..1b60b6e11b0e6c0b2cc8fe9bd2789d3a306de873 100644 (file)
@@ -1,2 +1 @@
-DIST gupnp-igd-0.2.4.tar.xz 272004 BLAKE2B d195187faab17fcb5510afec0d024071936c5d61ac9ce4b4fd266cbc1ac238876935b588d91d7e55d3280ded4a0b39560a3b3bdbfec9cbccc3ab883ab1f75e1c SHA512 4da8d401935c4237661310aec0acb38e9c9fe54aeb6b2ef1c9533a8576dbd2d9f9db3b50c4e86b7efc81c80059a10ea52f73517dab23f3cdc0f91a5c0944dab8
 DIST gupnp-igd-0.2.5.tar.xz 287964 BLAKE2B 2267b991a0137006f122b3454bfb1bd9df0fd7fae2c47b50a394a2859f6e04375b55447830f6606c8a25260b9cafb75329cbdcd201c220a66fe881dce368abfe SHA512 3d2af29d10c2939a81c8745a50d9cc20be53f97a2112cec6e45bf05373d807d86404b61c776fea34b15ac341f9b7bfff2f3c48901dd241e64e18b5bc7e614cc8
diff --git a/net-libs/gupnp-igd/files/gupnp-igd-0.1.11-disable_static_modules.patch b/net-libs/gupnp-igd/files/gupnp-igd-0.1.11-disable_static_modules.patch
deleted file mode 100644 (file)
index ccd4b8d..0000000
+++ /dev/null
@@ -1,10 +0,0 @@
---- a/python/Makefile.am
-+++ b/python/Makefile.am
-@@ -27,7 +28,7 @@
- igd_la_LDFLAGS =                                      \
--      -module -avoid-version
-+      -module -avoid-version -shared
- pygupnp-igd.c: $(srcdir)/pygupnp-igd.override $(srcdir)/pygupnp-igd.defs
-       $(PYCODEGEN)                                            \
diff --git a/net-libs/gupnp-igd/gupnp-igd-0.2.4.ebuild b/net-libs/gupnp-igd/gupnp-igd-0.2.4.ebuild
deleted file mode 100644 (file)
index 2b84b9c..0000000
+++ /dev/null
@@ -1,109 +0,0 @@
-# Copyright 1999-2018 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 )
-AUTOTOOLS_AUTORECONF=true
-
-inherit eutils gnome.org python-r1 multilib-minimal xdg-utils
-
-DESCRIPTION="Library to handle UPnP IGD port mapping for GUPnP"
-HOMEPAGE="http://gupnp.org"
-
-LICENSE="LGPL-2"
-SLOT="0"
-KEYWORDS="~alpha amd64 ~arm hppa ~ia64 ~ppc ppc64 ~sparc x86"
-IUSE="+introspection python"
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-
-RDEPEND="
-       >=dev-libs/glib-2.34.3:2[${MULTILIB_USEDEP}]
-       >=net-libs/gssdp-0.14.7[${MULTILIB_USEDEP}]
-       >=net-libs/gupnp-0.20.10[${MULTILIB_USEDEP}]
-       introspection? ( >=dev-libs/gobject-introspection-0.10 )
-       python? (
-               ${PYTHON_DEPS}
-               >=dev-libs/gobject-introspection-0.10
-               >=dev-python/pygobject-2.16:2[${PYTHON_USEDEP}]
-       )"
-DEPEND="${RDEPEND}
-       dev-util/glib-utils
-       dev-util/gtk-doc-am
-       sys-devel/gettext
-       >=virtual/pkgconfig-0-r1[${MULTILIB_USEDEP}]
-"
-
-# The only existing test is broken
-RESTRICT="test"
-
-PATCHES=(
-       "${FILESDIR}"/${PN}-0.1.11-disable_static_modules.patch
-)
-
-multilib_src_configure() {
-       xdg_environment_reset
-
-       local myconf=(
-               --disable-static
-               --disable-gtk-doc
-               $(multilib_native_use_enable introspection)
-               # python is built separately
-               --disable-python
-       )
-
-       ECONF_SOURCE=${S} \
-       econf "${myconf[@]}"
-
-       if multilib_is_native_abi; then
-               ln -s "${S}"/doc/html doc/html || die
-
-               python_configure() {
-                       mkdir -p "${BUILD_DIR}" || die
-                       cd "${BUILD_DIR}" || die
-
-                       ECONF_SOURCE=${S} \
-                       econf "${myconf[@]}" \
-                               --enable-python
-               }
-
-               use python && python_foreach_impl python_configure
-       fi
-}
-
-multilib_src_compile() {
-       default
-
-       if multilib_is_native_abi && use python; then
-               local native_builddir=${BUILD_DIR}
-
-               python_compile() {
-                       emake -C "${BUILD_DIR}"/python \
-                               VPATH="${S}/python:${native_builddir}/python" \
-                               igd_la_LIBADD="\$(PYGUPNP_IGD_LIBS) ${native_builddir}/libgupnp-igd/libgupnp-igd-1.0.la"
-               }
-
-               python_foreach_impl python_compile
-       fi
-}
-
-multilib_src_install() {
-       default
-
-       if multilib_is_native_abi && use python; then
-               local native_builddir=${BUILD_DIR}
-
-               python_install() {
-                       emake -C "${BUILD_DIR}"/python \
-                               VPATH="${S}/python:${native_builddir}/python" \
-                               DESTDIR="${D}" install
-               }
-
-               python_foreach_impl python_install
-       fi
-}
-
-multilib_src_install_all() {
-       einstalldocs
-       prune_libtool_files
-}