dev-ros/rqt_image_view: bump to 0.4.8 and update to split repos
authorAlexis Ballier <aballier@gentoo.org>
Tue, 25 Apr 2017 05:40:29 +0000 (07:40 +0200)
committerAlexis Ballier <aballier@gentoo.org>
Tue, 25 Apr 2017 06:40:05 +0000 (08:40 +0200)
Package-Manager: Portage-2.3.5, Repoman-2.3.2

dev-ros/rqt_image_view/Manifest
dev-ros/rqt_image_view/metadata.xml
dev-ros/rqt_image_view/rqt_image_view-0.4.8.ebuild [new file with mode: 0644]
dev-ros/rqt_image_view/rqt_image_view-9999.ebuild

index 7bb8c4d74093009871a7fac050b5df5b997ec913..1bfbd8cdce86381ba3d4dfc2f849e9b6a754e750 100644 (file)
@@ -1 +1,2 @@
 DIST rqt_common_plugins-0.4.7.tar.gz 246977 SHA256 83153ad89c67551c3fb4f36cad7f056d90c559958ac80203e2aa4605beb49a7f SHA512 eb10a7c03bb079d939a9705a08e9194c83e020235a13ed2d4ff8e9c3c73e5abbd0a9bd7c00587135767497b155bb9516d7b4c2240fbe2118d7b0668d6ee32ab7 WHIRLPOOL b002f836ee0f5ea213ec31be8e59910c7c3c9508301389309e60eeb7dd35989ae4e4dfa5fa9ee592371f05e6cd842a6e3b0ccd6ac4ed7a9efd8d60c36b1e6d65
+DIST rqt_image_view-0.4.8.tar.gz 11360 SHA256 ce5356b6ccdbdae70fde35ef77bbbc5b2f5d2402bc6507a625f49569266d0651 SHA512 aac22362a58fc5a0a7912c85a2b71c22cdf5fa6afd0806a521fe60ae9c9fb8f6eced773fcc548aadb4aea0c5c45fe70dabf08e6283076136f76443135da9e416 WHIRLPOOL 85d7f693f6485814777fe79f4432019609c86798e51cc7875fed42334ac27131c2dabd732ae398ea6d585c659f5d876f196e762aef82db6b72340967a1750326
index cb473d142b8e7ce5b6c875e4ff9f5c2ac8c49e79..6ccce36045be416ffc5676041881c7d2c3e03231 100644 (file)
@@ -6,6 +6,6 @@
                <name>Gentoo ROS Project</name>
        </maintainer>
        <upstream>
-               <remote-id type="github">ros-visualization/rqt_common_plugins</remote-id>
+               <remote-id type="github">ros-visualization/rqt_image_view</remote-id>
        </upstream>
 </pkgmetadata>
diff --git a/dev-ros/rqt_image_view/rqt_image_view-0.4.8.ebuild b/dev-ros/rqt_image_view/rqt_image_view-0.4.8.ebuild
new file mode 100644 (file)
index 0000000..2b7acfd
--- /dev/null
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+KEYWORDS="~amd64"
+ROS_REPO_URI="https://github.com/ros-visualization/rqt_image_view"
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="GUI plugin for displaying images using image_transport"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+       dev-ros/cv_bridge[${PYTHON_USEDEP}]
+       media-libs/opencv:=
+       dev-ros/image_transport
+       dev-ros/rqt_gui[${PYTHON_USEDEP}]
+       >=dev-ros/rqt_gui_cpp-0.3
+       dev-ros/sensor_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+       dev-qt/qtwidgets:5
+"
+DEPEND="${RDEPEND}"
index a3ec846362180988f8e4f731fdf04304c9f8ade6..2b7acfd6d24512dd9d18b736641d6a9b32572b18 100644 (file)
@@ -4,9 +4,8 @@
 EAPI=5
 
 KEYWORDS="~amd64"
-ROS_REPO_URI="https://github.com/ros-visualization/rqt_common_plugins"
+ROS_REPO_URI="https://github.com/ros-visualization/rqt_image_view"
 PYTHON_COMPAT=( python2_7 )
-ROS_SUBDIR=${PN}
 
 inherit ros-catkin