sci-libs/geos: --disable-inline with arm
authorAndreas Sturmlechner <asturm@gentoo.org>
Sat, 28 Mar 2020 12:54:04 +0000 (13:54 +0100)
committerAndreas Sturmlechner <asturm@gentoo.org>
Sat, 28 Mar 2020 12:55:59 +0000 (13:55 +0100)
Bug: https://bugs.gentoo.org/709368
Package-Manager: Portage-2.3.96, Repoman-2.3.22
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
sci-libs/geos/geos-3.8.0-r1.ebuild
sci-libs/geos/geos-3.8.1.ebuild

index 3992d7a58cfd0671ff895f6cd370049f6ec561a4..e8fc86859c7843a75d99df1d1794393f4bade8c7 100644 (file)
@@ -33,10 +33,14 @@ src_prepare() {
 }
 
 src_configure() {
-       econf \
-               --disable-python \
-               $(use_enable ruby) \
+       local myeconfargs=(
+               --disable-python
+               $(use_enable ruby)
                $(use_enable static-libs static)
+       )
+       use arm && myeconfargs+=( --disable-inline ) # bug 709368
+
+       econf "${myeconfargs[@]}"
 }
 
 src_compile() {
index ad70d2dd21cade159157b2ff3a3ad60451ae5015..f19227d4b28982100558403a3d20d28e03bfcaf7 100644 (file)
@@ -34,6 +34,8 @@ src_configure() {
                $(use_enable ruby)
                $(use_enable static-libs static)
        )
+       use arm && myeconfargs+=( --disable-inline ) # bug 709368
+
        econf "${myeconfargs[@]}"
 }