net-analyzer/metasploit: drop openvas-omp support
authorHasan ÇALIŞIR <hasan.calisir@psauxit.com>
Tue, 29 Oct 2019 14:47:29 +0000 (17:47 +0300)
committerJoonas Niilola <juippis@gentoo.org>
Tue, 29 Oct 2019 17:29:31 +0000 (19:29 +0200)
set slot on dev-ruby/rubyzip.
drop openvas-omp support.

Closes: https://bugs.gentoo.org/698762
Package-Manager: Portage-2.3.76, Repoman-2.3.16
Signed-off-by: Hasan ÇALIŞIR <hasan.calisir@psauxit.com>
Closes: https://github.com/gentoo/gentoo/pull/13488
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
net-analyzer/metasploit/metasploit-4.17.21-r6.ebuild
net-analyzer/metasploit/metasploit-9999.ebuild

index e24648b0588f4020809b8d5aa1056a395a76f98a..db815de8d1d61bcb70e96d95ccb68296c6792194 100644 (file)
@@ -92,7 +92,7 @@ RUBY_COMMON_DEPEND="virtual/ruby-ssl
        dev-ruby/ruby-macho
        dev-ruby/rubyntlm
        dev-ruby/ruby_smb:*
-       dev-ruby/rubyzip
+       dev-ruby/rubyzip:*
        dev-ruby/sqlite3
        dev-ruby/sshkey
        dev-ruby/tzinfo:*
@@ -215,6 +215,12 @@ all_ruby_prepare() {
        #if ! use nessus; then
                sed -i -e "/nessus/d" metasploit-framework.gemspec || die
        #fi
+
+       #OpenVAS support dropped on net-analyzer/metasploit. Bug:692076
+       #openvas-omp is deprecated and masked for removal. Bug:692076
+       #Remove openvas-omp in gemspec. Bug:698762
+       sed -i -e "/openvas-omp/d" metasploit-framework.gemspec || die
+
        #even if we pass --without=blah bundler still calculates the deps and messes us up
        if ! use development; then
                sed -i -e "/^group :development do/,/^end$/d" Gemfile || die
index 08d45194b38729073f31f765e64b2657852ead02..42bf6440d53d0c14ee76146be3b304d17b3f3a67 100644 (file)
@@ -91,7 +91,7 @@ RUBY_COMMON_DEPEND="virtual/ruby-ssl
        dev-ruby/ruby-macho
        dev-ruby/rubyntlm
        dev-ruby/ruby_smb:*
-       dev-ruby/rubyzip
+       dev-ruby/rubyzip:*
        dev-ruby/sqlite3
        dev-ruby/sshkey
        dev-ruby/tzinfo:*
@@ -214,6 +214,12 @@ all_ruby_prepare() {
        #if ! use nessus; then
                sed -i -e "/nessus/d" metasploit-framework.gemspec || die
        #fi
+
+       #OpenVAS support dropped on net-analyzer/metasploit. Bug:692076
+       #openvas-omp is deprecated and masked for removal. Bug:692076
+       #Remove openvas-omp in gemspec. Bug:698762
+       sed -i -e "/openvas-omp/d" metasploit-framework.gemspec || die
+
        #even if we pass --without=blah bundler still calculates the deps and messes us up
        if ! use development; then
                sed -i -e "/^group :development do/,/^end$/d" Gemfile || die